Project

General

Profile

Bug #7901

Pages fail to load correctly

Added by Jake Callahan over 7 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Immediate
Assignee:
-
Category:
Web UI
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

When navigating to any of the pages below, the user is presented with a blank screen. Opening the browser console output window shows the errors below.

Affected pages
--------------
Content
- Lifecycle Environments
- Red Hat Subscriptions
- Activation Keys
- Products
- GPG Keys
- Sync Plans
- Content Views

Hosts
- Content Hosts
- Host Collections

Console Output
--------------
Uncaught SyntaxError: Unexpected token bastion-a9ee28c734d01db9aecd1a7217caf4ef.js:5
from Json bastion-a9ee28c734d01db9aecd1a7217caf4ef.js:5
(anonymous function) activation_keys:29

Uncaught Error: [$injector:modulerr] Failed to instantiate module Bastion.activation-keys due to:
Error: [$injector:modulerr] Failed to instantiate module Bastion due to:
Error: [$injector:unpr] Unknown provider: BastionConfig
http://errors.angularjs.org/1.2.9/$injector/unpr?p0=BastionConfig
at https://qe-foreman-rhel65.usersys.redhat.com/assets/bastion/bastion-a9ee28c734d01db9aecd1a7217caf4ef.js:5:21189
at https://qe-foreman-rhel65.usersys.redhat.com/assets/bastion/bastion-a9ee28c734d01db9aecd1a7217caf4ef.js:6:15508
at getService (https://qe-foreman-rhel65.usersys.redhat.com/assets/bastion/bastion-a9ee28c734d01db9aecd1a7217caf4ef.js:6:14118)
at Object.invoke (https://qe-foreman-rhel65.usersys.redhat.com/assets/bastion/bastion-a9ee28c734d01db9aecd1a7217caf4ef.js:6:14566)
at https://qe-foreman-rhel65.usersys.redhat.com/assets/bastion/bastion-a9ee28c734d01db9aecd1a7217caf4ef.js:6:13308
at Array.forEach (native)
at forEach (https://qe-foreman-rhel65.usersys.redhat.com/assets/bastion/bastion-a9ee28c734d01db9aecd1a7217caf4ef.js:5:21686)
at loadModules (https://qe-foreman-rhel65.usersys.redhat.com/assets/bastion/bastion-a9ee28c734d01db9aecd1a7217caf4ef.js:6:12888)
at https://qe-foreman-rhel65.usersys.redhat.com/assets/bastion/bastion-a9ee28c734d01db9aecd1a7217caf4ef.js:6:13075
at Array.forEach (native)
http://errors.angularjs.org/1.2.9/$injector/modulerr?p0=Bastion&p1=Error%3A…aecd1a7217caf4ef.js%3A6%3A13075%0A%20%20%20%20at%20Array.forEach%20(native)
at https://qe-foreman-rhel65.usersys.redhat.com/assets/bastion/bastion-a9ee28c734d01db9aecd1a7217caf4ef.js:5:21189
at https://qe-foreman-rhel65.usersys.redhat.com/assets/bastion/bastion-a9ee28c734d01db9aecd1a7217caf4ef.js:6:13648
at Array.forEach (native)
at forEach (https://qe-foreman-rhel65.usersys.redhat.com/assets/bastion/bastion-a9ee28c734d01db9aecd1a7217caf4ef.js:5:21686)
at loadModules (https://qe-foreman-rhel65.usersys.redhat.com/assets/bastion/bastion-a9ee28c734d01db9aecd1a7217caf4ef.js:6:12888)
at https://qe-foreman-rhel65.usersys.redhat.com/assets/bastion/bastion-a9ee28c734d01db9aecd1a7217caf4ef.js:6:13075
at Array.forEach (native)
at forEach (https://qe-foreman-rhel65.usersys.redhat.com/assets/bastion/bastion-a9ee28c734d01db9aecd1a7217caf4ef.js:5:21686)
at loadModules (https://qe-foreman-rhel65.usersys.redhat.com/assets/bastion/bastion-a9ee28c734d01db9aecd1a7217caf4ef.js:6:12888)
at createInjector (https://qe-foreman-rhel65.usersys.redhat.com/assets/bastion/bastion-a9ee28c734d01db9aecd1a7217caf4ef.js:6:15827)
http://errors.angularjs.org/1.2.9/$injector/modulerr?p0=Bastion.activation-…assets%2Fbastion%2Fbastion-a9ee28c734d01db9aecd1a7217caf4ef.js%3A6%3A15827)
bastion-a9ee28c734d01db9aecd1a7217caf4ef.js:5


Related issues

Is duplicate of Katello - Bug #7900: Bastion pages fail to load due to error in CurrentUser JSONClosed2014-10-10

History

#1 Updated by Dominic Cleal over 7 years ago

  • Project changed from Foreman to Katello
  • Category changed from Web Interface to Web UI
  • Legacy Backlogs Release (now unused) deleted (21)
  • Triaged set to No

#2 Updated by Eric Helms over 7 years ago

  • Is duplicate of Bug #7900: Bastion pages fail to load due to error in CurrentUser JSON added

#3 Updated by Eric Helms over 7 years ago

  • Status changed from New to Duplicate

#4 Updated by Eric Helms over 7 years ago

  • Triaged changed from No to Yes

#5 Updated by Eric Helms over 7 years ago

  • Legacy Backlogs Release (now unused) set to 14

#6 Updated by Eric Helms about 7 years ago

  • Legacy Backlogs Release (now unused) deleted (14)

#7 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF