Project

General

Profile

Bug #7946

Cannot initiate synchronization of a custom repo from

Added by Og Maciel over 7 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Noticed that one cannot initiate the synchronization of a custom repository from the Products page. Behind the scenes the following error is being returned by the API call to

/katello/api/v2/repositories/bulk/sync?organization_id=1
:

uninitialized constant Actions::BulkAction
Steps:
  • Create a new product from the web UI
  • Create a custom repo and point it to a valid yum or Docker repo
  • Once the repo is created, select it and click the Sync Now button (see attached screenshot)
Environment:
  • candlepin-0.9.32-1.el7.noarch
  • candlepin-common-1.0.8-1.el7.noarch
  • candlepin-selinux-0.9.32-1.el7.noarch
  • candlepin-tomcat-0.9.32-1.el7.noarch
  • elasticsearch-0.90.10-7.el7.noarch
  • foreman-1.7.0-0.develop.201410141236git8e0f91f.el7.noarch
  • foreman-compute-1.7.0-0.develop.201410141236git8e0f91f.el7.noarch
  • foreman-gce-1.7.0-0.develop.201410141236git8e0f91f.el7.noarch
  • foreman-libvirt-1.7.0-0.develop.201410141236git8e0f91f.el7.noarch
  • foreman-ovirt-1.7.0-0.develop.201410141236git8e0f91f.el7.noarch
  • foreman-postgresql-1.7.0-0.develop.201410141236git8e0f91f.el7.noarch
  • foreman-proxy-1.7.0-0.develop.201410101404git7961640.el7.noarch
  • foreman-release-1.7.0-0.develop.201410141012git7a10a14.el7.noarch
  • foreman-selinux-1.7.0-0.develop.201409301113git2f345de.el7.noarch
  • foreman-vmware-1.7.0-0.develop.201410141236git8e0f91f.el7.noarch
  • katello-2.1.0-1.201410141018git9231e24.el7.noarch
  • katello-certs-tools-2.0.1-1.el7.noarch
  • katello-default-ca-1.0-1.noarch
  • katello-installer-2.1.0-1.201410021645git304e036.el7.noarch
  • katello-repos-2.1.1-1.el7.noarch
  • katello-server-ca-1.0-1.noarch
  • openldap-2.4.39-3.el7.x86_64
  • pulp-docker-plugins-0.2.1-0.2.beta.el7.noarch
  • pulp-katello-0.3-3.el7.noarch
  • pulp-nodes-common-2.5.0-0.7.beta.el7.noarch
  • pulp-nodes-parent-2.5.0-0.7.beta.el7.noarch
  • pulp-puppet-plugins-2.5.0-0.7.beta.el7.noarch
  • pulp-puppet-tools-2.5.0-0.7.beta.el7.noarch
  • pulp-rpm-plugins-2.5.0-0.7.beta.el7.noarch
  • pulp-selinux-2.5.0-0.7.beta.el7.noarch
  • pulp-server-2.5.0-0.7.beta.el7.noarch
  • python-ldap-2.4.6-6.el7.x86_64
  • ruby193-rubygem-ldap_fluff-0.3.1-1.el7.noarch
  • ruby193-rubygem-net-ldap-0.3.1-2.el7.noarch
  • ruby193-rubygem-runcible-1.2.0-1.el7.noarch
  • rubygem-hammer_cli-0.1.3-1.201409240954gitf3c47c7.el7.noarch
  • rubygem-hammer_cli_foreman-0.1.3-1.201409191432gitc38f9c8.el7.noarch
  • rubygem-hammer_cli_foreman_tasks-0.0.3-2.201409091410git163c264.git.0.988ca80.el7.noarch
  • rubygem-hammer_cli_import-0.10.4-1.el7.noarch
  • rubygem-hammer_cli_katello-0.0.6-1.201410141047gitb3ec23e.git.0.764fcf0.el7.noarch

History

#1 Updated by Eric Helms about 7 years ago

  • Priority changed from Normal to High
  • Target version set to 59
  • Legacy Backlogs Release (now unused) set to 14
  • Triaged changed from No to Yes

#2 Updated by Eric Helms about 7 years ago

  • Status changed from New to Closed

I tested this with latest nightly and was not able to reproduce. If you are still seeing the issue, please re-open.

Also available in: Atom PDF