Project

General

Profile

Bug #7995

Unable to escape build mode for hosts with expired tokens

Added by Lukas Zapletal almost 5 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Unattended installations
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

1. Create new host
2. Let the token to expire (set token_duration to one minute and wait or modify using the console).
3. Unattended URL now does not work (expected) *
4. Locate the host in the UI, click on Cancel build. Error.

Since we have token_duration set to one hour by default, we can expect those errors on deployments with slow installations.


Related issues

Related to Foreman - Bug #7994: Set token_duration to 6 hours instead of one hourClosed2014-10-20

History

#1 Updated by Lukas Zapletal almost 5 years ago

  • Related to Bug #7994: Set token_duration to 6 hours instead of one hour added

#2 Updated by Dominic Cleal almost 5 years ago

  • Category set to Unattended installations
  • Status changed from New to Need more information

I'm not sure what you're trying to say here. If the token's expired then this is by design.

There however shouldn't be an error (what error?) in the UI when you cancel the build, that sounds like another issue.

#3 Updated by Lukas Zapletal over 3 years ago

  • Status changed from Need more information to Closed

Not able to reproduce with develop, hosts with expired tokens now exit build mode cleanly.

#4 Updated by Dominic Cleal over 3 years ago

  • Status changed from Closed to Rejected

Also available in: Atom PDF