Project

General

Profile

Bug #8008

URL, user and password no longer shown when installer has a non-fatal error

Added by Dominic Cleal about 6 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
foreman-installer script
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

#5488 changed the installer to a hook layout which only shows information about the configured Puppet modules, the username, password and URLs, when the run was successful.

This is a regression since https://github.com/theforeman/foreman-installer/commit/0fcebfbf15e94e1f4f88229d7a4b517374f69599 which made it always show the output, as sometimes the error is non-fatal.

Associated revisions

Revision bb5944a0 (diff)
Added by Shlomi Zadok about 6 years ago

fixes #8008 - display foreman, foreman-proxy and puppet regradless to success or fail

History

#1 Updated by Dominic Cleal about 6 years ago

  • Target version set to 1.7.2

#2 Updated by Shlomi Zadok about 6 years ago

  • Assignee set to Shlomi Zadok

#3 Updated by Shlomi Zadok about 6 years ago

  • Status changed from New to Ready For Testing

#4 Updated by Dominic Cleal about 6 years ago

  • Pull request https://github.com/theforeman/foreman-installer/pull/132 added
  • Pull request deleted ()

#5 Updated by Shlomi Zadok about 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF