Project

General

Profile

Bug #8041

katello-installer --no-enable-foreman / "" is not a boolean. It looks to be a String at /usr/share/katello-installer/modules/foreman/manifests/config/passenger.pp:52

Added by Joseph Womack over 7 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

In the 2.0 and the daily release (katello-2.1.0-1.201410221634gitac15899.el6.noarch) fail with a puppet error:
Launching installer with command: katello-installer --no-enable-foreman
"" is not a boolean. It looks to be a String at /usr/share/katello-installer/modules/foreman/manifests/config/passenger.pp:52 on node chmxappktl001.mgt.expecn.com
"" is not a boolean. It looks to be a String at /usr/share/katello-installer/modules/foreman/manifests/config/passenger.pp:52 on node chmxappktl001.mgt.expecn.com
Preparing installation Done
Something went wrong! Check the log for ERROR-level output
The full log is at /var/log/katello-installer/katello-installer.log

Looking at the module on line 52: validate_bool($ssl)

I have tried to use the following command as well:
katello-installer --no-enable-foreman --foreman-ssl=false

It results in the same error.

My question is why is this module even being called with the --no-enable-foreman option?

[root@chmxappktl001 katello-deploy]# rpm -qi foreman
Name : foreman Relocations: (not relocatable)
Version : 1.6.1 Vendor: Koji
Release : 1.el6 Build Date: Tue 07 Oct 2014 08:13:19 AM PDT
Install Date: Wed 22 Oct 2014 02:33:51 PM PDT Build Host: ip-10-88-183-59.ec2.internal
Group : Applications/System Source RPM: foreman-1.6.1-1.el6.src.rpm
Size : 13720317 License: GPLv3+ with exceptions
Signature : RSA/SHA1, Wed 08 Oct 2014 12:07:38 AM PDT, Key ID a91e2984667d1f07
Packager : Koji
URL : http://theforeman.org
Summary : Systems Management web application
Description :
Foreman is aimed to be a Single Address For All Machines Life Cycle Management.
Foreman is based on Ruby on Rails, and this package bundles Rails and all
plugins required for Foreman to work.

History

#1 Updated by Joseph Womack over 7 years ago

Uploaded: rsync://theforeman.org/debug-incoming/foreman-debug-XBplA.tar.xz

#2 Updated by Dominic Cleal over 7 years ago

  • Project changed from Installer to Katello
  • Triaged set to No

#3 Updated by Eric Helms over 7 years ago

  • Status changed from New to Rejected
  • Triaged changed from No to Yes

The katello-installer is not intended to be run with the Foreman module disabled. While kafo, the underlying library exposes this type of functionality, the installer is not built to handle (nor does it make sense) this case.

#4 Updated by Joseph Womack over 7 years ago

I'm confused on why this option does not make sense. If it does not make sense, why is it there? If I want to install foreman and katello on different servers, how do I accomplish this?

#5 Updated by Eric Helms over 7 years ago

Why the options exist:

The options exist because of how kafo (https://github.com/theforeman/kafo) the underlying framework on which our installer is built exposes options. If you look here (https://github.com/Katello/katello-installer/blob/master/config/answers.katello-installer.yaml) you will see the answers file that is by default configured for the katello-installer. In this setup, we require the certs, foreman and katello puppet modules and define some initial configuration for them. Kafo looks at the answers file and exposes a --no-enable option for each of the top level modules defined here. You could argue that due to this we should push the Foreman and Certs declarations into the Katello init.pp so that they are not exposed here nor as --no-enable options which I think would be a fair issue (but I am not sure that it would be high priority).

Foreman and Katello on different servers:

This setup does not make sense. Katello is now a Rails engine/plugin to Foreman and thus is integrated into how Foreman works. The code must all be loaded together by the same application server. Some users have requested the ability to install Katello's dependencies (Pulp and Candlepin) on different servers. That is about the best we can do. If this is actually what you want, then I'd encourage you to up vote (or create where missing) issues to this point.

Hope that helps. If you have more questions feel free to raise them here, on the mailing list or in IRC.

#6 Updated by Eric Helms over 7 years ago

  • Legacy Backlogs Release (now unused) set to 14

#7 Updated by Eric Helms about 7 years ago

  • Legacy Backlogs Release (now unused) deleted (14)

#8 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF