Project

General

Profile

Bug #8061

Need a better error message for failed uploads from the CLI

Added by David Davis almost 5 years ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Hammer
Target version:
-
Difficulty:
easy
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

When uploading repository content, we just have a generic error message:

hammer repository upload-content --id 1 --path tmp/scratch.tar
Failed to upload file 'scratch.tar' to repository. Please check the file and try again.

It would be nice to tell the user exactly what failed. Not sure if pulp tells us the exact error though (like failing to unzip/read a file).

History

#1 Updated by Eric Helms almost 5 years ago

  • Difficulty set to easy
  • Triaged changed from No to Yes

#2 Updated by Greg Swift about 4 years ago

This really needs a higher priority if this is one of the primary ways to manually upload content

#3 Updated by Eric Helms almost 4 years ago

  • Legacy Backlogs Release (now unused) set to 86

#4 Updated by Eric Helms over 3 years ago

  • Legacy Backlogs Release (now unused) changed from 86 to 114

#5 Updated by John Mitsch about 2 months ago

  • Status changed from New to Closed

Thanks for reporting this issue. This issue was created over 4 years ago and hasn't seen an update in 1 year. We are closing this in an effort to keep a realistic backlog. Please open up a new issue that includes a link to this issue if you feel this still needs to be addressed. We can then triage the new issue and reassess.

#6 Updated by Justin Sherrill about 2 months ago

  • Target version deleted (Katello Backlog)

Also available in: Atom PDF