Project

General

Profile

Tracker #8121

Remote Execution Tracker

Added by David Caplan almost 5 years ago. Updated about 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

This tracker provides user stories that cover all things related to Remote Execution. This feature allows operators to create scripts, snippets, etc, archive and version them, and schedule them for execution on one or more remote host (being managed by Satellite 6).


Related issues

Related to Salt - Feature #7311: Command console for running other salt commandsNew2014-08-30
Related to Foreman - Tracker #3505: As a user I'd like to have Remote ManagementResolved2013-10-25

Related to Foreman Remote Execution - Feature #8157: As a user I would like to ability to rollback the changes invoked by the execution of a remote command manifest (within reason)Need more information2014-10-29
Related to Foreman Remote Execution - Feature #8158: As a user I would like to monitor the operational status of an invocation of remote commands Resolved2014-10-29
Related to Foreman Remote Execution - Feature #9893: Remote Execution DesignClosed2015-03-25
Blocked by Foreman Remote Execution - Feature #8122: As a user I would like to create a script or manifest of remote commands and apply it to one or more systemsResolved2014-10-27
Blocked by Foreman Remote Execution - Feature #8143: As a user I would like to be able to edit the remote command manifest and re-apply it to one or more systemsResolved2014-10-28
Blocked by Foreman Remote Execution - Feature #8155: As a user I would like to clone/copy an existing remote command manifest, modify the copy and apply it to one or more systemsResolved2014-10-28

History

#1 Updated by Thomas McKay almost 5 years ago

  • Blocked by Feature #8122: As a user I would like to create a script or manifest of remote commands and apply it to one or more systems added

#2 Updated by Thomas McKay almost 5 years ago

  • Related to Feature #7311: Command console for running other salt commands added

#3 Updated by Thomas McKay almost 5 years ago

  • Related to Tracker #3505: As a user I'd like to have Remote Management added

#4 Updated by Thomas McKay almost 5 years ago

[[https://www.youtube.com/watch?v=vMMoBTG9Zfg]]

Foreman deep dive: remote management with MCollective

#5 Updated by David Caplan almost 5 years ago

  • Blocked by Feature #8142: As a user I would like remote command scripts to leverage smart variables added

#6 Updated by David Caplan almost 5 years ago

  • Blocked by Feature #8143: As a user I would like to be able to edit the remote command manifest and re-apply it to one or more systems added

#7 Updated by David Caplan almost 5 years ago

  • Blocked by Feature #8155: As a user I would like to clone/copy an existing remote command manifest, modify the copy and apply it to one or more systems added

#8 Updated by David Caplan almost 5 years ago

  • Related to Feature #8157: As a user I would like to ability to rollback the changes invoked by the execution of a remote command manifest (within reason) added

#9 Updated by David Caplan almost 5 years ago

  • Related to Feature #8158: As a user I would like to monitor the operational status of an invocation of remote commands added

#10 Updated by David Caplan almost 5 years ago

  • Blocked by Feature #8159: As a system I want the application of remote commands to retry on failure on a per system basis added

#11 Updated by Ivan Necas over 4 years ago

#12 Updated by Dominic Cleal about 3 years ago

  • Project changed from Foreman to Foreman Remote Execution
  • Category deleted (70)

#13 Updated by Marek Hulán about 3 years ago

I think this is duplicate of #10760, all requirements are considered implemented.

#14 Updated by Marek Hulán about 3 years ago

  • Blocked by deleted (Feature #8142: As a user I would like remote command scripts to leverage smart variables)

#15 Updated by Marek Hulán about 3 years ago

  • Blocked by deleted (Feature #8159: As a system I want the application of remote commands to retry on failure on a per system basis)

#16 Updated by Marek Hulán about 3 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF