Project

General

Profile

Bug #8205

[katello 2.0] "/" in name field of metadata.json or Modulefile of uploaded puppetclass causes browser to freak out from

Added by Garrett D over 7 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

If I upload a puppet module to a puppet repo and add it to a content view, the browser will start a reload loop IF the puppet module in question is formulated as author/modulename instead of author-modulename in the "name" field of the metadata.json or Modulefile of the module.

Changing this field to author-modulename, and uploading to a fresh repository seems to be a good workaround currently. However, Puppet 3.7.2 puts the slash by default if using puppet module generate.

My setup is:

RHEL7
Katello 2.0
Puppet 3.7.2
Browsers -- I've reproduced this on Firefox, IE and Chrome.

History

#1 Updated by Garrett D over 7 years ago

Well, I did some more research and it appears I was generating my puppet modules incorrectly. Puppet docs say to use "-" and not "/" anyways.

#2 Updated by Eric Helms over 7 years ago

  • Status changed from New to Need more information
  • Triaged changed from No to Yes

Based on your comment -- do you still consider this an issue?

#3 Updated by Eric Helms over 6 years ago

  • Status changed from Need more information to Resolved

#4 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF