Project

General

Profile

Feature #8239

Allow MAC address parameter for /unattended, in addition to RHN headers

Added by Anonymous almost 8 years ago. Updated about 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Unattended installations
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

We plan to use an iPXE workflow to provision hosts, without having to set DHCP leases, and need to be able to generate the /unattended/iPXE template from an IP address which is not the one set for the host in Foreman. It would be awesome if the find_host_by_ip_or_mac method in UnattendedController could look for a mac_address GET parameter, in addition to the RHN-specific headers. I would then be able to set this parameter from iPXE.


Related issues

Related to Smart Proxy - Bug #10259: Template proxy does not lookup by MAC addressClosed2015-04-24
Is duplicate of Foreman - Feature #22756: Allow provisioning based on "mac" parameterClosed2018-03-04

History

#1 Updated by Dominic Cleal over 7 years ago

https://github.com/theforeman/foreman/pull/1106 tried this and has been closed, for the record.

#2 Updated by Dominic Cleal over 7 years ago

  • Related to Bug #10259: Template proxy does not lookup by MAC address added

#3 Updated by Anonymous over 7 years ago

Thank you Dominic. You showed me this pull request a while back and I used it in our deployment. Our current patch is available (https://github.com/cloudwatt/foreman/commit/9249735b76967999fff20f03edf632e469d5b94a) but, like the original pull request, doesn't have any test. It's one of the reason I don't submit a new pull request. The other is that, for the whole iPXE chain to work properly, we also need another patch (https://github.com/cloudwatt/foreman/commit/5462ac4eeb240155944ee80a6829395cd338480b) which, although quite small, is rather intrusive :) It allows for ipxe templates to be rendered with any authentication.

We have been using those two patches in our deployment for a while (with pre-release versions of 1.8), and they allow us to not need any DHCP and TFTP smart-proxy. Everything is done through HTTP requests to foreman, and IPs are configured on the nodes using the new interface capability and some custom chef code.

#4 Updated by Timo Goebel about 4 years ago

  • Is duplicate of Feature #22756: Allow provisioning based on "mac" parameter added

#5 Updated by Timo Goebel about 4 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF