Project

General

Profile

Tracker #8360

Full journald support

Added by Lukas Zapletal about 7 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Category:
Packaging
Target version:
-
% Done:

0%

Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Tracker bug for all journald logging support.

On RHEL7 we should leverage journald sending all the logs there for:

- foreman core app
- plugins (katello, candlepin, pulp)
- foreman proxies
- cron jobs (using systemd-cat)

When possible, we should send logging levels properly as well, so users are able to leverage fine-grained filtering system in journald (WARN, ERROR, DEBUG, TRACE).

Let's also make sure that timestamps are correctly sent and we leverage all the journald goodies.


Related issues

Related to Smart Proxy - Feature #8006: Implement logging to stdout/stderrClosed2014-10-21
Related to Foreman - Feature #7033: Syslog capabilityDuplicate2014-08-12
Is duplicate of Foreman - Feature #9561: [RFE] Write structured logs to journaldDuplicate2015-02-26
Is duplicate of Katello - Feature #9560: [RFE] Write structured logs to journaldDuplicate2015-02-26

History

#1 Updated by Lukas Zapletal about 7 years ago

  • Related to Feature #8006: Implement logging to stdout/stderr added

#2 Updated by Lukas Zapletal about 7 years ago

Note we need to disable timestamps when in journald/syslog mode. It would be best to have a switch for that. Otherwise the output looks ugly in the journal:

Nov 13 16:20:48 fdi smart-proxy[553]: I, [2014-11-13T16:20:48.080405 #553]  INFO -- : 'realm' module is disabled.

#3 Updated by Lukas Zapletal almost 7 years ago

  • Is duplicate of Feature #9561: [RFE] Write structured logs to journald added

#4 Updated by Lukas Zapletal almost 7 years ago

  • Is duplicate of Feature #9560: [RFE] Write structured logs to journald added

#5 Updated by Lukas Zapletal almost 7 years ago

  • Status changed from New to Duplicate

Hello, we already track this effort, but since we still fully support RHEL 6 systems, we don't rush with this.

#6 Updated by Lukas Zapletal almost 7 years ago

  • Category set to Packaging
  • Status changed from Duplicate to New

#7 Updated by Dominic Cleal over 6 years ago

#8 Updated by Lukas Zapletal almost 4 years ago

  • Assignee set to Lukas Zapletal
  • Status changed from New to Duplicate

Done, in nightly as #22569

Also available in: Atom PDF