Project

General

Profile

Bug #8368

Installer fails on RHEL 7 due to missing `rake` requirement.

Added by Og Maciel about 7 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
Installer
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

QE has had issues using the nightly katello-installer on RHEL 7. The commands we're using are:

git clone https://github.com/Katello/katello-deploy.git
cd katello-deploy && ./setup.rb --skip-installer --os rhel7

From this point onward we don't touch the machine and let the script run its course, but eventually we get this error:

Execution of '/usr/bin/yum -d 0 -e 0 -y install rubygem-smart_proxy_pulp' returned 1: Error: Package: foreman-proxy-1.8.0-0.develop.201411111731git81c679e.el7.noarch (foreman)
[10.8.29.189] out: [ INFO 2014-11-12 03:17:07 verbose]            Requires: rubygem(rake) >= 0.8.3

The interesting thing is that the the channel that should provide me ``rake`` (rhel-7-server-optional-rpms) is enables as can be seen by some of the steps taken by the installer:

[10.8.29.189] out: Installing:
[10.8.29.189] out:  rhscl-v8314-epel-7-x86_64 noarch 1-2   /rhscl-v8314-epel-7-x86_64.noarch 152  
[10.8.29.189] out: 
[10.8.29.189] out: Transaction Summary
[10.8.29.189] out: ================================================================================
[10.8.29.189] out: Install  1 Package
[10.8.29.189] out: 
[10.8.29.189] out: Total size: 152  
[10.8.29.189] out: Installed size: 152  
[10.8.29.189] out: Downloading packages:
[10.8.29.189] out: Running transaction check
[10.8.29.189] out: Running transaction test
[10.8.29.189] out: Transaction test succeeded
[10.8.29.189] out: Running transaction
[10.8.29.189] out: 
[10.8.29.189] out:   Installing : rhscl-v8314-epel-7-x86_64-1- [                             ] 1/1
[10.8.29.189] out:   Installing : rhscl-v8314-epel-7-x86_64-1- [####################         ] 1/1
[10.8.29.189] out:   Installing : rhscl-v8314-epel-7-x86_64-1-2.noarch                         1/1 
[10.8.29.189] out: 
[10.8.29.189] out: rhel-7-server-extras-rpms/x86_64                         | 2.9 kB     00:00     
[10.8.29.189] out: 
[10.8.29.189] out: rhel-7-server-extras-rpms/x86_64/updateinfo              | 5.5 kB     00:00     
[10.8.29.189] out: 
[10.8.29.189] out: rhel-7-server-extras-rpms/x86_64/primary_db              |  10 kB     00:00     
[10.8.29.189] out: 
[10.8.29.189] out: rhel-7-server-optional-rpms/7Server/x86_64               | 2.9 kB     00:00     
[10.8.29.189] out: 
[10.8.29.189] out: rhel-7-server-optional-rpms/7Server/x86_64/updateinfo    |  93 kB     00:00     
[10.8.29.189] out: 
[10.8.29.189] out: rhel-7-server-optional-rp 85% [============-  ]  0.0 B/s | 1.5 MB     --:-- ETA 
[10.8.29.189] out: 
[10.8.29.189] out: rhel-7-server-optional-rpms/7Server/x86_64/primary_db    | 1.8 MB     00:00     
[10.8.29.189] out: 
[10.8.29.189] out: rhel-7-server-rpms/7Server/x86_64                        | 3.7 kB     00:00     
[10.8.29.189] out: 
[10.8.29.189] out: rhel-server-rhscl-7-rpms/7Server/x86_64                  | 3.1 kB     00:00     
[10.8.29.189] out: 
[10.8.29.189] out:   Verifying  : rhscl-v8314-epel-7-x86_64-1-2.noarch                         1/1 
[10.8.29.189] out: 
[10.8.29.189] out: Installed:
[10.8.29.189] out:   rhscl-v8314-epel-7-x86_64.noarch 0:1-2                                        
[10.8.29.189] out: 
[10.8.29.189] out: Complete!

I can provide a full fledged log (via email) if you want to get more information.

History

#1 Updated by Eric Helms about 7 years ago

  • Target version set to 62
  • Legacy Backlogs Release (now unused) set to 14
  • Triaged changed from No to Yes

#2 Updated by Og Maciel about 7 years ago

  • Status changed from New to Closed

QE has successfully installed latest code on RHEL 7.

Also available in: Atom PDF