Project

General

Profile

Bug #8374

warning in hammer ping command

Added by Suresh Thirugnanasambandan almost 8 years ago. Updated over 7 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:
In Kanboard:

Description

warning in hammer ping command

  1. hammer -u admin -p changeme ping
    /usr/lib/ruby/gems/1.8/gems/hammer_cli-0.1.3/lib/hammer_cli/./apipie/../abstract.rb:67: warning: already initialized constant DEFAULT_LABEL_INDENT
    candlepin:
    Status: ok
    Server Response: Duration: 29ms
    candlepin_auth:
    Status: ok
    Server Response: Duration: 35ms
    pulp:
    Status: ok
    Server Response: Duration: 17ms
    pulp_auth:
    Status: ok
    Server Response: Duration: 23ms
    elasticsearch:
    Status: ok
    Server Response: Duration: 15ms
    foreman_tasks:
    Status: ok
    Server Response: Duration: 0ms

Related issues

Is duplicate of Hammer CLI - Bug #7635: warning: already initialized constant DEFAULT_LABEL_INDENTClosed2014-09-25

Associated revisions

Revision f8918041
Added by Tomáš Strachota over 7 years ago

Merge pull request #162 from komidore64/bz1195690

fixes #8374 - fixing warning of already initialized constant, BZ1195690

History

#1 Updated by Suresh Thirugnanasambandan almost 8 years ago

this happens for all hammer commands

#2 Updated by Adam Price almost 8 years ago

  • Assignee set to Adam Price

#3 Updated by Adam Price almost 8 years ago

i'm unable to reproduce when i installed hammer in ruby1.8.7 on my local dev machine. thanks.

#4 Updated by Suresh Thirugnanasambandan over 7 years ago

This happened in today's nightly.

Ruby: ruby-1.8.7.374-2.el6.x86_64

  1. cat /etc/redhat-release
    Red Hat Enterprise Linux Server release 6.6 (Santiago)
Other packages:
  • apr-util-ldap-1.3.9-3.el6_0.1.x86_64
  • candlepin-0.9.34-1.el6.noarch
  • candlepin-common-1.0.14-1.el6.noarch
  • candlepin-selinux-0.9.34-1.el6.noarch
  • candlepin-tomcat6-0.9.34-1.el6.noarch
  • elasticsearch-0.90.10-7.el6.noarch
  • foreman-1.8.0-0.develop.201411181249gita2fc4fb.el6.noarch
  • foreman-compute-1.8.0-0.develop.201411181249gita2fc4fb.el6.noarch
  • foreman-gce-1.8.0-0.develop.201411181249gita2fc4fb.el6.noarch
  • foreman-libvirt-1.8.0-0.develop.201411181249gita2fc4fb.el6.noarch
  • foreman-ovirt-1.8.0-0.develop.201411181249gita2fc4fb.el6.noarch
  • foreman-postgresql-1.8.0-0.develop.201411181249gita2fc4fb.el6.noarch
  • foreman-proxy-1.8.0-0.develop.201411121327gitab6edc2.el6.noarch
  • foreman-release-1.8.0-0.develop.201411181249gita2fc4fb.el6.noarch
  • foreman-selinux-1.8.0-0.develop.201410280941git10de1c5.el6.noarch
  • foreman-vmware-1.8.0-0.develop.201411181249gita2fc4fb.el6.noarch
  • katello-2.1.0-1.201411061509gitb0b8f43.el6.noarch
  • katello-certs-tools-2.0.1-1.el6.noarch
  • katello-default-ca-1.0-1.noarch
  • katello-installer-2.1.0-1.201411172212git9d6f424.el6.noarch
  • katello-repos-2.1.1-1.el6.noarch
  • katello-server-ca-1.0-1.noarch
  • openldap-2.4.39-8.el6.x86_64
  • pulp-docker-plugins-0.2.1-0.2.beta.el6.noarch
  • pulp-katello-0.3-3.el6.noarch
  • pulp-nodes-common-2.5.0-0.7.beta.el6.noarch
  • pulp-nodes-parent-2.5.0-0.7.beta.el6.noarch
  • pulp-puppet-plugins-2.5.0-0.7.beta.el6.noarch
  • pulp-puppet-tools-2.5.0-0.7.beta.el6.noarch
  • pulp-rpm-plugins-2.5.0-0.7.beta.el6.noarch
  • pulp-selinux-2.5.0-0.7.beta.el6.noarch
  • pulp-server-2.5.0-0.7.beta.el6.noarch
  • python-ldap-2.3.10-1.el6.x86_64
  • ruby193-rubygem-ldap_fluff-0.3.3-1.el6.noarch
  • ruby193-rubygem-net-ldap-0.3.1-2.el6.noarch
  • ruby193-rubygem-runcible-1.3.0-1.el6.noarch

#5 Updated by Bryan Kearney over 7 years ago

  • Bugzilla link set to 1195690

#6 Updated by Dominic Cleal over 7 years ago

  • Is duplicate of Bug #7635: warning: already initialized constant DEFAULT_LABEL_INDENT added

#7 Updated by Dominic Cleal over 7 years ago

  • Status changed from New to Duplicate

#8 Updated by Tomáš Strachota over 7 years ago

  • Related to Bug #9714: Clean up requires inside hammer-cli gem added

#9 Updated by Tomáš Strachota over 7 years ago

  • Related to deleted (Bug #9714: Clean up requires inside hammer-cli gem)

Also available in: Atom PDF