Project

General

Profile

Bug #8542

14.04 installer misses rgen gem install

Added by John Brooker almost 5 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Debian/Ubuntu
Target version:
-
Difficulty:
easy
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Default installation of the foreman-proxy server (as part of the foreman-installer setup) does not include the missing "RGEN" gem dependency:

hostA:/var/log/foreman$ sudo service foreman-proxy start
/usr/share/foreman-proxy/lib/smart_proxy.rb:97:in `instance_eval': cannot load such file -- rgen/metamodel_builder (LoadError)
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/lib/ruby/vendor_ruby/puppet/pops/model/model.rb:23:in `<top (required)>'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/lib/ruby/vendor_ruby/puppet/pops.rb:20:in `<module:Pops>'
    from /usr/lib/ruby/vendor_ruby/puppet/pops.rb:3:in `<module:Puppet>'
    from /usr/lib/ruby/vendor_ruby/puppet/pops.rb:1:in `<top (required)>'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/share/foreman-proxy/modules/puppet_proxy/class_scanner_eparser.rb:5:in `<top (required)>'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/share/foreman-proxy/modules/puppet_proxy/puppet_class.rb:2:in `<top (required)>'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/share/foreman-proxy/modules/puppet_proxy/environment.rb:4:in `<top (required)>'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/share/foreman-proxy/modules/puppet_proxy/puppet_api.rb:1:in `<top (required)>'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from (eval):1:in `block (2 levels) in https_app'
    from /usr/share/foreman-proxy/lib/smart_proxy.rb:97:in `instance_eval'
    from /usr/share/foreman-proxy/lib/smart_proxy.rb:97:in `block (2 levels) in https_app'
    from /usr/share/foreman-proxy/lib/smart_proxy.rb:97:in `each'
    from /usr/share/foreman-proxy/lib/smart_proxy.rb:97:in `block in https_app'
    from /usr/lib/ruby/vendor_ruby/rack/builder.rb:55:in `instance_eval'
    from /usr/lib/ruby/vendor_ruby/rack/builder.rb:55:in `initialize'
    from /usr/share/foreman-proxy/lib/smart_proxy.rb:96:in `new'
    from /usr/share/foreman-proxy/lib/smart_proxy.rb:96:in `https_app'
    from /usr/share/foreman-proxy/lib/smart_proxy.rb:125:in `launch'
    from /usr/share/foreman-proxy/bin/smart-proxy:6:in `<main>'
hostA:/var/log/foreman$ sudo aptitude install ruby-rgen
The following NEW packages will be installed:
  ruby-rgen 
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 68.7 kB of archives. After unpacking 457 kB will be used.
Get: 1 http://archive.ubuntu.com/ubuntu/ trusty/main ruby-rgen all 0.6.6-1 [68.7 kB]
Fetched 68.7 kB in 0s (154 kB/s)   
Selecting previously unselected package ruby-rgen.
(Reading database ... 107389 files and directories currently installed.)
Preparing to unpack .../ruby-rgen_0.6.6-1_all.deb ...
Unpacking ruby-rgen (0.6.6-1) ...
Setting up ruby-rgen (0.6.6-1) ...

hostA:/var/log/foreman$ sudo service foreman-proxy start
hostA:/var/log/foreman$ 

History

#2 Updated by Dominic Cleal almost 5 years ago

  • Project changed from Foreman to Packaging
  • Category changed from Proxy gateway to Debian/Ubuntu
  • Status changed from New to Ready For Testing

#3 Updated by Michael Moll over 4 years ago

  • Status changed from Ready For Testing to Rejected

Also available in: Atom PDF