Project

General

Profile

Bug #8543

Creation/Addition of Classes

Added by kevin masteller about 8 years ago. Updated about 8 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

I am unable to create classes, assign classes to environments, or delete classes in foreman. The only way these actions can be performed is by running puppet module install/uninstall, then importing changes to foreman.

The issue appears centered around the 'Puppet environments' selector in the create/edit class tab. The 'Puppet environments' selector is always grayed out, even when an imported class has an associated environment.

History

#1 Updated by Dominic Cleal about 8 years ago

  • Status changed from New to Rejected

This is by design, it's meant to work via the Puppet class import only nowadays.

Also available in: Atom PDF