Project

General

Profile

Actions

Bug #8552

closed

Seeing errors on a new katello install for the "Listen on candlepin events" task

Added by David Davis over 9 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Fixed in Releases:
Found in Releases:

Description

Action:
Actions::Candlepin::ListenOnCandlepinEvents

Input:
{"locale"=>"en"}

Output:
{"messages"=>0, "last_message"=>nil}

Exception:
Katello::Configuration::Node::NoKey:  missing key 'qpid' in configuration

Backtrace:
/home/dadavis/Projects/katello/lib/katello/configuration/node.rb:85:in `rescue in method_missing'
/home/dadavis/Projects/katello/lib/katello/configuration/node.rb:82:in `method_missing'
/home/dadavis/Projects/katello/app/lib/actions/candlepin/listen_on_candlepin_events.rb:153:in `initialize_listening_service'
/home/dadavis/Projects/katello/app/lib/actions/candlepin/listen_on_candlepin_events.rb:129:in `block in initialize_service'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/action.rb:356:in `call'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/action.rb:356:in `suspend'
/home/dadavis/Projects/katello/app/lib/actions/candlepin/listen_on_candlepin_events.rb:125:in `initialize_service'
/home/dadavis/Projects/katello/app/lib/actions/candlepin/listen_on_candlepin_events.rb:67:in `block in run'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/algebrick-0.4.0/lib/algebrick.rb:859:in `block in assigns'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/algebrick-0.4.0/lib/algebrick.rb:858:in `tap'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/algebrick-0.4.0/lib/algebrick.rb:858:in `assigns'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/algebrick-0.4.0/lib/algebrick.rb:138:in `match_value'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/algebrick-0.4.0/lib/algebrick.rb:116:in `block in match'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/algebrick-0.4.0/lib/algebrick.rb:115:in `each'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/algebrick-0.4.0/lib/algebrick.rb:115:in `match'
/home/dadavis/Projects/katello/app/lib/actions/candlepin/listen_on_candlepin_events.rb:64:in `run'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/action.rb:456:in `block (3 levels) in execute_run'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/middleware/stack.rb:26:in `call'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/middleware/stack.rb:26:in `pass'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/middleware.rb:16:in `pass'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/action/progress.rb:30:in `with_progress_calculation'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/action/progress.rb:16:in `run'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/middleware/stack.rb:22:in `call'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/middleware/stack.rb:26:in `pass'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/middleware.rb:16:in `pass'
/home/dadavis/Projects/katello/app/lib/actions/middleware/keep_locale.rb:24:in `block in run'
/home/dadavis/Projects/katello/app/lib/actions/middleware/keep_locale.rb:35:in `with_locale'
/home/dadavis/Projects/katello/app/lib/actions/middleware/keep_locale.rb:24:in `run'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/middleware/stack.rb:22:in `call'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/middleware/world.rb:30:in `execute'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/action.rb:455:in `block (2 levels) in execute_run'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/action.rb:454:in `catch'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/action.rb:454:in `block in execute_run'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/action.rb:371:in `call'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/action.rb:371:in `block in with_error_handling'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/action.rb:371:in `catch'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/action.rb:371:in `with_error_handling'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/action.rb:449:in `execute_run'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/action.rb:236:in `execute'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/execution_plan/steps/abstract_flow_step.rb:9:in `block (2 levels) in execute'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/execution_plan/steps/abstract.rb:152:in `call'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/execution_plan/steps/abstract.rb:152:in `with_meta_calculation'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/execution_plan/steps/abstract_flow_step.rb:8:in `block in execute'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/execution_plan/steps/abstract_flow_step.rb:22:in `open_action'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/execution_plan/steps/abstract_flow_step.rb:7:in `execute'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/executors/parallel/worker.rb:20:in `block in on_message'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/algebrick-0.4.0/lib/algebrick.rb:859:in `block in assigns'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/algebrick-0.4.0/lib/algebrick.rb:858:in `tap'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/algebrick-0.4.0/lib/algebrick.rb:858:in `assigns'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/algebrick-0.4.0/lib/algebrick.rb:138:in `match_value'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/algebrick-0.4.0/lib/algebrick.rb:116:in `block in match'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/algebrick-0.4.0/lib/algebrick.rb:115:in `each'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/algebrick-0.4.0/lib/algebrick.rb:115:in `match'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/executors/parallel/worker.rb:17:in `on_message'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/micro_actor.rb:82:in `on_envelope'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/micro_actor.rb:72:in `receive'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/micro_actor.rb:99:in `block (2 levels) in run'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/micro_actor.rb:99:in `loop'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/micro_actor.rb:99:in `block in run'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/micro_actor.rb:99:in `catch'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/micro_actor.rb:99:in `run'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/dynflow-0.7.5/lib/dynflow/micro_actor.rb:13:in `block in initialize'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/logging-1.8.2/lib/logging/diagnostic_context.rb:323:in `call'
/home/dadavis/.rvm/gems/ruby-2.0.0-p594@foreman/gems/logging-1.8.2/lib/logging/diagnostic_context.rb:323:in `block in create_with_logging_context'
caused by: (NoMethodError) undefined method `qpid' for #<Katello::Configuration::Node:0x0000000b3003f8>
/home/dadavis/Projects/katello/lib/katello/configuration/node.rb:83:in `method_missing'
    ... skipped 62 lines
Actions #1

Updated by David Davis over 9 years ago

  • Assignee set to dustin tsang
Actions #2

Updated by Eric Helms over 9 years ago

  • Target version set to 62
  • Translation missing: en.field_release set to 14
  • Triaged changed from No to Yes
Actions #3

Updated by The Foreman Bot over 9 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/4849 added
  • Pull request deleted ()
Actions #4

Updated by Eric Helms over 9 years ago

  • Target version changed from 62 to 63
Actions #5

Updated by dustin tsang over 9 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF