Project

General

Profile

Actions

Bug #8598

closed

Repository delete results in failed task

Added by Justin Sherrill over 9 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
API
Target version:
Difficulty:
easy
Triaged:
Yes
Fixed in Releases:
Found in Releases:

Description

Deleting a Repository results in a failed task:

NoMethodError

undefined method `can?' for nil:NilClass

---
- /home/vagrant/katello/app/models/katello/authorization.rb:22:in `authorized?'
- /home/vagrant/katello/app/models/katello/authorization/product.rb:30:in `editable?'
- /home/vagrant/katello/app/models/katello/authorization/repository.rb:25:in `deletable?'
- /home/vagrant/katello/app/models/katello/repository.rb:474:in `assert_deletable'
- /home/vagrant/.rvm/gems/ruby-1.9.3-p448/gems/activesupport-3.2.21/lib/active_support/callbacks.rb:407:in
  `_run__3721688161599193244__destroy__1563448023527611882__callbacks'
- /home/vagrant/.rvm/gems/ruby-1.9.3-p448/gems/activesupport-3.2.21/lib/active_support/callbacks.rb:405:in
  `__run_callback'
- /home/vagrant/.rvm/gems/ruby-1.9.3-p448/gems/activesupport-3.2.21/lib/active_support/callbacks.rb:385:in
  `_run_destroy_callbacks'
- /home/vagrant/.rvm/gems/ruby-1.9.3-p448/gems/activesupport-3.2.21/lib/active_support/callbacks.rb:81:in
  `run_callbacks'
- /home/vagrant/.rvm/gems/ruby-1.9.3-p448/gems/activerecord-3.2.21/lib/active_record/callbacks.rb:254:in
  `destroy'
- /home/vagrant/.rvm/gems/ruby-1.9.3-p448/gems/activerecord-3.2.21/lib/active_record/transactio
Actions #1

Updated by Justin Sherrill over 9 years ago

Not able to reproduce this, but will re-test on a nightly.

Actions #2

Updated by The Foreman Bot over 9 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/4888 added
  • Pull request deleted ()
Actions #3

Updated by Justin Sherrill over 9 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100
Actions #4

Updated by Justin Sherrill over 9 years ago

  • Bugzilla link set to 1191662
Actions

Also available in: Atom PDF