Project

General

Profile

Bug #8624

On-the-fly user creation not working if user's name contains umlauts.

Added by Dirk Heinrichs about 5 years ago. Updated about 5 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
Authentication
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

One of my users can't login to the foreman web interface with LDAP (AD) authentication and on-the-fyl user creation enabled. In the log, I see the following error message:

Failed to save User 'XXX' ["Surname is invalid"]

The user's surname contains the german umlaut "ΓΌ".


Related issues

Is duplicate of Foreman - Bug #7548: Cannot use UTF8 characters as a user's login, firstname or lastnameClosed2014-09-19

History

#1 Updated by Dominic Cleal about 5 years ago

  • Is duplicate of Bug #7548: Cannot use UTF8 characters as a user's login, firstname or lastname added

#2 Updated by Dominic Cleal about 5 years ago

  • Status changed from New to Duplicate

Thanks for the report, but I think this is covered under ticket #7548 already (currently unresolved, but with a suggestion of a patch).

#3 Updated by Dirk Heinrichs about 5 years ago

Ah, sorry. Didn't see that.

Yes, the patch suggested in Bug #7548 works for me.

Also available in: Atom PDF