Project

General

Profile

Bug #8700

EL7 mongod.service typo in unit file

Added by Florian Koch over 5 years ago. Updated almost 2 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
Installer
Target version:
Difficulty:
trivial
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Hi,

i version 2.0.0 there is a typo in the MongoDB unit

This is the installed unit, the PIDFile Path is incorrect , this causes the installer to fail.

[Unit]
Description=High-performance, schema-free document-oriented database
After=syslog.target network.target

[Service]
Type=forking
User=mongodb
PIDFile=/var/run/mongodb/mongod.pid
EnvironmentFile=/etc/sysconfig/mongod
ExecStart=/usr/bin/mongod $OPTIONS run
PrivateTmp=true
LimitNOFILE=64000

[Install]
WantedBy=multi-user.target

the correct unit changing mongod.pid to mongodb.pid and it works

[Unit]
Description=High-performance, schema-free document-oriented database
After=syslog.target network.target

[Service]
Type=forking
User=mongodb
PIDFile=/var/run/mongodb/mongodb.pid
EnvironmentFile=/etc/sysconfig/mongod
ExecStart=/usr/bin/mongod $OPTIONS run
PrivateTmp=true
LimitNOFILE=64000

[Install]
WantedBy=multi-user.target


Related issues

Is duplicate of Katello - Bug #8478: MongoDB fails to start with a RHEL 7 systemClosed2014-11-21

History

#1 Updated by Florian Koch over 5 years ago

  • Is duplicate of Bug #8478: MongoDB fails to start with a RHEL 7 system added

#2 Updated by Florian Koch over 5 years ago

sorry for the dup, found this already reported after creating the new bug

#3 Updated by Eric Helms over 5 years ago

  • Status changed from New to Duplicate

#4 Updated by Eric Helms over 5 years ago

  • Triaged changed from No to Yes

#5 Updated by Eric Helms almost 4 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF