Project

General

Profile

Bug #8736

Confirmation missing from host page's delete button

Added by Dominic Cleal almost 7 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
High
Category:
Web Interface
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Prior to #2592, there was a JavaScript confirmation popup on the delete button on the host#show page which asked "Are you sure?", but it now seems to be missing and immediately deletes the host.


Related issues

Related to Foreman - Bug #2592: No indication when waiting for host dashboard button action to completeClosed2013-05-30
Related to Foreman - Bug #9558: Build button dialog does not work after editing hostDuplicate2015-02-25
Has duplicate Foreman - Bug #10370: Button OK is missing on Rebuild host confirmationRejected2015-05-05

Associated revisions

Revision 96277f87 (diff)
Added by Tomáš Strachota over 6 years ago

Fixes #8736 - confirmation before host delete for freshly created hosts

Revision b20fdb5e (diff)
Added by Tomáš Strachota over 6 years ago

Fixes #8736 - confirmation before host delete for freshly created hosts

(cherry picked from commit 96277f876959e1cd61c30cb8e28552e3183624da)

History

#1 Updated by Dominic Cleal almost 7 years ago

  • Related to Bug #2592: No indication when waiting for host dashboard button action to complete added

#2 Updated by Dominic Cleal almost 7 years ago

  • Legacy Backlogs Release (now unused) set to 28

#3 Updated by Dominic Cleal almost 7 years ago

This only happens immediately after host creation when it's finished orchestration and shows host info. If you visit or refresh the host#show page, it's fine.

#4 Updated by b sh almost 7 years ago

I will take care of it

#5 Updated by b sh almost 7 years ago

  • Assignee set to b sh

#6 Updated by b sh almost 7 years ago

The reason for this issue is that host.js file isn't loaded. It's odd, because it should have been.
I will do a deeper investigation. Hopefully, resolve it soon.

#7 Updated by Dominic Cleal over 6 years ago

  • Assignee deleted (b sh)

Just unsetting you as there's been no movement, please feel free to reassign if you're on it again :)

#8 Updated by Tomáš Strachota over 6 years ago

  • Status changed from New to Assigned
  • Assignee set to Tomáš Strachota

#9 Updated by Tomáš Strachota over 6 years ago

  • Status changed from Assigned to Need more information
  • Assignee deleted (Tomáš Strachota)

I can't reproduce the issue. The confirmation dialog pops up for me when I try to delete host from both the index and show page.
Is it any special scenario when this happens to you? Could you please confirm you still observe the problem?

#10 Updated by Dominic Cleal over 6 years ago

It still occurs for me - note comment 3 though, it only happens immediately after creating the host when the details are shown. If you visit the host#show page again or refresh it then the confirmation box works fine.

#11 Updated by Tomáš Strachota over 6 years ago

  • Assignee set to Tomáš Strachota

I see, I missed that, thanks! I'm going to test again.

#12 Updated by The Foreman Bot over 6 years ago

  • Status changed from Need more information to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2196 added
  • Pull request deleted ()

#13 Updated by Anonymous over 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#14 Updated by Dominic Cleal over 6 years ago

  • Related to Bug #9558: Build button dialog does not work after editing host added

#15 Updated by Dominic Cleal over 6 years ago

  • Has duplicate Bug #10370: Button OK is missing on Rebuild host confirmation added

Also available in: Atom PDF