Project

General

Profile

Feature #8780

Add a way to prevent reboot on failed deploy

Added by Jorick Astrego over 5 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Unattended installations
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Currently when a part of the post-install of the provisioning template fails the system never finishes the build and will reboot.

It will then try and build again and fail, putting it in a reboot loop.

You then have to search manually in the logs to see which part fails.

Can we have an option to prevent reboot on failed built and have the error sent to foreman?


Related issues

Related to Foreman - Feature #21007: Templates API to mark a build as failedClosed

History

#1 Updated by Ohad Levy over 5 years ago

just thinking out loud..

keep a counter of reboots, and zero it each time the system change from boot true to boot false.
if the counter is bigger than 3, alert and abort provisioning?

#2 Updated by Lukas Zapletal over 2 years ago

  • Related to Feature #21007: Templates API to mark a build as failed added

#3 Updated by Lukas Zapletal over 2 years ago

  • Status changed from New to Duplicate

Dupe of #21007 - we are going to tackle that. PR is pending review actually.

Also available in: Atom PDF