Project

General

Profile

Bug #8864

foreman_gutterball RPM doesn't install files to the right location

Added by Eric Helms over 7 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

The foreman_gutterball RPM installs files to /gems instead of inside the SCL and rooted at usr/share/gems within that. Current location:

/gems/foreman_gutterball-0.0.1

Proper location:

/opt/rh/ruby193/root/usr/share/gems/gems/foreman_gutterball-0.0.1

I believe the issue is with common macros being redefined and should be removed:

https://github.com/Katello/foreman-gutterball/blob/master/rubygem-foreman_gutterball.spec#L7-L8

For reference: https://github.com/theforeman/foreman-packaging/blob/rpm/develop/rubygem-bastion/rubygem-bastion.spec


Related issues

Blocks Katello - Tracker #5311: GutterballResolved2014-04-21

History

#3 Updated by Eric Helms over 7 years ago

#4 Updated by Eric Helms over 7 years ago

  • Target version changed from 63 to 66

#5 Updated by Eric Helms over 7 years ago

  • Status changed from New to Closed

Also available in: Atom PDF