Project

General

Profile

Bug #8883

Changes to puppetmaster field in hostgroup not propagating to hosts

Added by Adam Winberg almost 6 years ago. Updated over 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Was trying to get puppetrun via mcollective to work and realized that we had not populated the puppetmaster field for any of our hosts. All our hosts belong to host groups so I thought it would be a quick fix just to set the puppetmaster parameter in the relevant hostgroups, but this has no effect on the hosts belonging to the group.

Is this a bug or expected behaviour?


Related issues

Is duplicate of Foreman - Feature #2436: Ability to update Puppet CA and Puppet Master for multiple hostsNew2013-04-29

History

#1 Updated by Dominic Cleal almost 6 years ago

  • Is duplicate of Feature #2436: Ability to update Puppet CA and Puppet Master for multiple hosts added

#2 Updated by Dominic Cleal almost 6 years ago

  • Status changed from New to Duplicate

It's expected behaviour, somewhat unfortunately. Host groups act as templates of sorts for new hosts, so most attributes (with the exception of Puppet class associations) are copied to the host.

#2436 and other linked issues relate to this. As a workaround, you may want to use the hammer CLI to update hosts individually (you can do a hammer host list --search "hostgroup = foo" too).

Also available in: Atom PDF