Project

General

Profile

Feature #8888

hammer auth should support token based authentication

Added by Tomáš Strachota almost 7 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Hammer core
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:
In Kanboard:

Description

Token based authentication is on it's way to to be merged into the API. We should support it in hammer.
https://github.com/theforeman/foreman/pull/2052


Related issues

Related to Foreman - Feature #8852: add token-based authentication feature for APINew
Is duplicate of Hammer CLI - Feature #8016: Ability to use tokenized authentication to hammer in lieu of username/password in configuration file.Closed2014-10-21

History

#1 Updated by Tomáš Strachota almost 7 years ago

  • Related to Feature #8852: add token-based authentication feature for API added

#2 Updated by Dominic Cleal almost 7 years ago

Dupe of #8016?

#3 Updated by Tomáš Strachota almost 7 years ago

  • Status changed from New to Duplicate

Correct, it's a dupe. Closing.

#4 Updated by Tomáš Strachota almost 7 years ago

  • Is duplicate of Feature #8016: Ability to use tokenized authentication to hammer in lieu of username/password in configuration file. added

#5 Updated by Rahul Bajaj over 1 year ago

  • Status changed from Duplicate to Closed

Also available in: Atom PDF