Project

General

Profile

Bug #892

submit button is missing when host has no hostgroup and is managed

Added by Corey Osman over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

I am not sure how I arrived in this state but it might have something to do with me updating to host to a blank hostgroup from the api. #867

I can't update this host or change values because the submit button is missing.


Related issues

Related to Foreman - Bug #867: updating a host to belong to a null hostgroup doesn't workClosed2011-04-26

Associated revisions

Revision 3101f9a2 (diff)
Added by Amos Benari over 9 years ago

fixes #892 missing div close and some other html crimes.

Signed-off-by: Amos Benari <>

History

#1 Updated by Corey Osman over 9 years ago

Forgot to mention that if I unmanage the host the submit button becomes available.

#2 Updated by Corey Osman over 9 years ago

  • Target version set to 0.3

#3 Updated by Ohad Levy over 9 years ago

  • Status changed from New to Feedback

thats odd.. i can see the submit button on a non managed host without any hostgroup...

can you provide a screenshot?

#4 Updated by Ohad Levy over 9 years ago

Ohad Levy wrote:

can you provide a screenshot?

next time I'll look harder, I promise ;)

#5 Updated by Ohad Levy over 9 years ago

a few code has been changed around the submit button, can you please revisit this with the latest git?

thanks!

#6 Updated by Ohad Levy over 9 years ago

can you please double check if this still happens after our UI modifications? I cant reproduce it

#7 Updated by Corey Osman over 9 years ago

Ok I was able to reproduce this again and figured out the problem.

The problem is:

Safari Web browser.

This problem does not occur with firefox. However, if you use Safari (OSX) the submit button does not show up.

#8 Updated by Ohad Levy over 9 years ago

  • Category set to Web Interface
  • Assignee set to Amos Benari

#9 Updated by Amos Benari over 9 years ago

  • Status changed from Feedback to Ready For Testing
  • % Done changed from 0 to 100

#10 Updated by Ohad Levy over 9 years ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF