Project

General

Profile

Bug #8932

Content Promotion with 200+ Puppet Environments Hangs or Fails

Added by Greg Koch almost 7 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Content Views
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

We have 32 content views and 4 environments, which has generated 223 Puppet Environments. With this number of Puppet Environments promotions are hanging during the Dynflow finalization step "Content Update" and often failing with 406 errors. If we resume the task (2-3 times), it will eventually finish.

The following Dynflow step is where we encounter the error:

466: Actions::Katello::Foreman::ContentUpdate (error) [ 19.80s / 19.80s ]

Error:

ProxyAPI::ProxyException

ERF12-4115 [ProxyAPI::ProxyException]: Unable to get classes from Puppet for KT_xxxxxxx_dev_puppet_el5_x86_64_cv_42 ([RestClient::NotAcceptable]: 406 Not Acceptable) for proxy https://xxxxxxx.xxxxxxx.biz:9090/puppet

---
- /usr/share/foreman/lib/proxy_api/puppet.rb:27:in `rescue in classes'
- /usr/share/foreman/lib/proxy_api/puppet.rb:21:in `classes'
- /usr/share/foreman/app/services/puppet_class_importer.rb:155:in `actual_classes'
- /usr/share/foreman/app/services/puppet_class_importer.rb:78:in `new_classes_for'
- /usr/share/foreman/app/services/puppet_class_importer.rb:25:in `block in changes'
- /usr/share/foreman/app/services/puppet_class_importer.rb:24:in `each'
- /usr/share/foreman/app/services/puppet_class_importer.rb:24:in `changes'
- /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.0.0/app/services/katello/puppet_class_importer_extensions.rb:22:in
  `update_environment'
- /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.0.0/app/lib/katello/foreman.rb:37:in
  `update_puppet_environment'
- /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.0.0/app/lib/actions/katello/foreman/content_update.rb:32:in
  `finalize'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/action.rb:465:in
  `block (2 levels) in execute_finalize'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware/stack.rb:26:in
  `call'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware/stack.rb:26:in
  `pass'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware.rb:16:in
  `pass'
- /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.0.0/app/lib/actions/middleware/remote_action.rb:32:in
  `block in finalize'
- /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.0.0/app/lib/actions/middleware/remote_action.rb:58:in
  `block (2 levels) in as_remote_user'
- /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.0.0/app/lib/katello/util/thread_session.rb:85:in
  `set_pulp_config'
- /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.0.0/app/lib/actions/middleware/remote_action.rb:44:in
  `as_pulp_user'
- /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.0.0/app/lib/actions/middleware/remote_action.rb:57:in
  `block in as_remote_user'
- /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.0.0/app/lib/katello/util/thread_session.rb:92:in
  `set_cp_config'
- /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.0.0/app/lib/actions/middleware/remote_action.rb:39:in
  `as_cp_user'
- /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.0.0/app/lib/actions/middleware/remote_action.rb:56:in
  `as_remote_user'
- /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.0.0/app/lib/actions/middleware/remote_action.rb:32:in
  `finalize'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware/stack.rb:22:in
  `call'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware/stack.rb:26:in
  `pass'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware.rb:16:in
  `pass'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/action/progress.rb:30:in
  `with_progress_calculation'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/action/progress.rb:22:in
  `finalize'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware/stack.rb:22:in
  `call'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware/stack.rb:26:in
  `pass'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware.rb:16:in
  `pass'
- /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.0.0/app/lib/actions/middleware/keep_locale.rb:28:in
  `block in finalize'
- /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.0.0/app/lib/actions/middleware/keep_locale.rb:35:in
  `with_locale'
- /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.0.0/app/lib/actions/middleware/keep_locale.rb:28:in
  `finalize'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware/stack.rb:22:in
  `call'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware/world.rb:30:in
  `execute'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/action.rb:464:in
  `block in execute_finalize'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/action.rb:365:in
  `call'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/action.rb:365:in
  `block in with_error_handling'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/action.rb:365:in
  `catch'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/action.rb:365:in
  `with_error_handling'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/action.rb:463:in
  `execute_finalize'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/action.rb:230:in
  `execute'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/execution_plan/steps/abstract_flow_step.rb:9:in
  `block (2 levels) in execute'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/execution_plan/steps/abstract.rb:152:in
  `call'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/execution_plan/steps/abstract.rb:152:in
  `with_meta_calculation'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/execution_plan/steps/abstract_flow_step.rb:8:in
  `block in execute'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/execution_plan/steps/abstract_flow_step.rb:22:in
  `open_action'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/execution_plan/steps/abstract_flow_step.rb:7:in
  `execute'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/executors/parallel/sequential_manager.rb:72:in
  `run_step'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/executors/parallel/sequential_manager.rb:57:in
  `dispatch'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/executors/parallel/sequential_manager.rb:64:in
  `block in run_in_sequence'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/executors/parallel/sequential_manager.rb:64:in
  `each'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/executors/parallel/sequential_manager.rb:64:in
  `all?'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/executors/parallel/sequential_manager.rb:64:in
  `run_in_sequence'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/executors/parallel/sequential_manager.rb:53:in
  `dispatch'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/executors/parallel/sequential_manager.rb:28:in
  `block (2 levels) in finalize'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware/stack.rb:26:in
  `call'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware/stack.rb:26:in
  `pass'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware.rb:16:in
  `pass'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware.rb:41:in
  `finalize_phase'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware/stack.rb:22:in
  `call'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware/stack.rb:26:in
  `pass'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware.rb:16:in
  `pass'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware.rb:41:in
  `finalize_phase'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware/stack.rb:22:in
  `call'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware/stack.rb:26:in
  `pass'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware.rb:16:in
  `pass'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware.rb:41:in
  `finalize_phase'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware/stack.rb:22:in
  `call'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/middleware/world.rb:30:in
  `execute'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/executors/parallel/sequential_manager.rb:27:in
  `block in finalize'
- /opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/connection_adapters/abstract/database_statements.rb:192:in
  `transaction'
- /opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/transactions.rb:208:in
  `transaction'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/transaction_adapters/active_record.rb:5:in
  `transaction'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/executors/parallel/sequential_manager.rb:24:in
  `finalize'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/executors/parallel/worker.rb:23:in
  `block in on_message'
- /opt/rh/ruby193/root/usr/share/gems/gems/algebrick-0.4.0/lib/algebrick.rb:859:in
  `block in assigns'
- /opt/rh/ruby193/root/usr/share/gems/gems/algebrick-0.4.0/lib/algebrick.rb:858:in
  `tap'
- /opt/rh/ruby193/root/usr/share/gems/gems/algebrick-0.4.0/lib/algebrick.rb:858:in
  `assigns'
- /opt/rh/ruby193/root/usr/share/gems/gems/algebrick-0.4.0/lib/algebrick.rb:138:in
  `match_value'
- /opt/rh/ruby193/root/usr/share/gems/gems/algebrick-0.4.0/lib/algebrick.rb:116:in
  `block in match'
- /opt/rh/ruby193/root/usr/share/gems/gems/algebrick-0.4.0/lib/algebrick.rb:115:in
  `each'
- /opt/rh/ruby193/root/usr/share/gems/gems/algebrick-0.4.0/lib/algebrick.rb:115:in
  `match'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/executors/parallel/worker.rb:17:in
  `on_message'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/micro_actor.rb:82:in
  `on_envelope'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/micro_actor.rb:72:in
  `receive'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/micro_actor.rb:99:in
  `block (2 levels) in run'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/micro_actor.rb:99:in
  `loop'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/micro_actor.rb:99:in
  `block in run'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/micro_actor.rb:99:in
  `catch'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/micro_actor.rb:99:in
  `run'
- /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.3/lib/dynflow/micro_actor.rb:13:in
  `block in initialize'
- /opt/rh/ruby193/root/usr/share/gems/gems/logging-1.8.1/lib/logging/diagnostic_context.rb:323:in
  `call'
- /opt/rh/ruby193/root/usr/share/gems/gems/logging-1.8.1/lib/logging/diagnostic_context.rb:323:in
  `block in create_with_logging_context'

From foreman-proxy/proxy.log:

10.60.141.42 - - [13/Jan/2015 12:51:42] "GET /environments/KT_xxxxxxx_prod_centos_6_server_x86_64_cv__16/classes HTTP/1.1" 200 2 2.4716
I, [2015-01-13T12:51:43.053304 #63199]  INFO -- : Initializing from Puppet config file: /etc/puppet/puppet.conf
I, [2015-01-13T12:51:43.146193 #63199]  INFO -- : Initializing from Puppet config file: /etc/puppet/puppet.conf
I, [2015-01-13T12:51:45.108623 #63199]  INFO -- : Initializing from Puppet config file: /etc/puppet/puppet.conf
I, [2015-01-13T12:51:45.141426 #63199]  INFO -- : Initializing from Puppet config file: /etc/puppet/puppet.conf
I, [2015-01-13T12:51:45.143053 #63199]  INFO -- : Initializing from Puppet config file: /etc/puppet/puppet.conf
I, [2015-01-13T12:51:45.250840 #63199]  INFO -- : Initializing from Puppet config file: /etc/puppet/puppet.conf
I, [2015-01-13T12:51:45.252718 #63199]  INFO -- : Initializing from Puppet config file: /etc/puppet/puppet.conf
I, [2015-01-13T12:51:45.414303 #63199]  INFO -- : Initializing from Puppet config file: /etc/puppet/puppet.conf
E, [2015-01-13T12:51:45.414820 #63199] ERROR -- : Failed to show puppet classes: Error converting value for param 'modulepath': Error converting value for param 'basemodulepath': Could not find value for $confdir
10.60.141.42 - - [13/Jan/2015 12:51:45] "GET /environments/KT_xxxxxxx_dev_puppet_el5_x86_64_cv_42/classes HTTP/1.1" 406 162 2.3751
I, [2015-01-13T12:51:45.433601 #63199]  INFO -- : Initializing from Puppet config file: /etc/puppet/puppet.conf
I, [2015-01-13T12:51:45.522164 #63199]  INFO -- : Initializing from Puppet config file: /etc/puppet/puppet.conf
10.60.141.42 - - [13/Jan/2015 12:51:45] "GET /environments/KT_xxxxxxx_qa_rhel_5_8_server_x86_64_cv_69/classes HTTP/1.1" 200 2 2.7583
I, [2015-01-13T12:51:45.603873 #63199]  INFO -- : Initializing from Puppet config file: /etc/puppet/puppet.conf
I, [2015-01-13T12:51:45.702921 #63199]  INFO -- : Initializing from Puppet config file: /etc/puppet/puppet.conf
I, [2015-01-13T12:51:47.561855 #63199]  INFO -- : Initializing from Puppet config file: /etc/puppet/puppet.conf
I, [2015-01-13T12:51:47.662264 #63199]  INFO -- : Initializing from Puppet config file: /etc/puppet/puppet.conf
I, [2015-01-13T12:51:47.731477 #63199]  INFO -- : Initializing from Puppet config file: /etc/puppet/puppet.conf
I, [2015-01-13T12:51:47.748059 #63199]  INFO -- : Initializing from Puppet config file: /etc/puppet/puppet.conf
I, [2015-01-13T12:51:47.830031 #63199]  INFO -- : Initializing from Puppet config file: /etc/puppet/puppet.conf

foreman-debug-2Fosd.tar.xz foreman-debug-2Fosd.tar.xz 505 KB foreman-debug after error occurred. Greg Koch, 01/13/2015 12:59 PM

Related issues

Is duplicate of Katello - Bug #9647: Publish/Promotion times in Satellite 6 growing after each publish/promotionClosed2015-03-04

History

#1 Updated by Eric Helms almost 7 years ago

  • Status changed from New to Need more information
  • Legacy Backlogs Release (now unused) set to 23
  • Triaged changed from No to Yes

Would you be able to give us a list of the puppet environments, content views and environments? The math isn't adding up for what we expect given what you have mentioned and that might help us debug if and what might be going wrong.

#2 Updated by Greg Koch almost 7 years ago

We determined that many of the Environments in /etc/puppet/environments were simply not cleaned up after removing Content Views. We calculated that for 4 environments (listed below) and the Library, and with 32 Content Views (see list below), we should have ended up with 160 Environments (unless something else is broken causing these to be created), We cleaned up the list from almost 220 Environments to 183, that list is below. This operation still hangs and often fails with the error in the original report.

Lifecycle Environments
  • Development (dev)
  • QA (qa)
  • Staging (staging)
  • Production (prod)
Content Views
  • centos-6-x86_64-comp-cv
  • centos-6-x86_64-cv
  • centos-6.5-x86_64-comp-cv
  • centos-6.5-x86_64-cv
  • centos-6.6-x86_64-comp-cv
  • centos-6.6-x86_64-cv
  • centos-7-x86_64-comp-cv
  • centos-7-x86_64-cv
  • dell-cv
  • epel-5-x86_64-cv
  • epel-6-x86_64-cv
  • epel-7-x86_64-cv
  • foreman-el6-x86_64-cv
  • hp-centos-cv
  • hp-rhel-cv
  • katello-client-el5-x86_64-cv
  • katello-client-el6-x86_64-cv
  • katello-server-el6-x86_64-cv
  • network-tools-cv
  • puppet-el5-x86_64-cv
  • puppet-rhel6-x86_64-cv
  • sharedsvc-centos-6-x86_64-comp-cv
  • vmware-el5-x86_64-cv
  • vmware-el6-x86_64-cv
  • rhel-5.8-x86_64-comp-cv
  • rhel-5.8-x86_64-cv
  • rhel-6-x86_64-comp-cv
  • rhel-6-x86_64-cv
  • rhel-6.4-x86_64-comp-cv
  • rhel-6.4-x86_64-cv
  • rhel-6.6-x86_64-comp-cv
  • rhel-6.6-x86_64-cv
Puppet Environments
  • example_env
  • KT_Organization_dev_centos_6_5_x86_64_cv__15
  • KT_Organization_dev_centos_6_5_x86_64_comp_cv_56
  • KT_Organization_dev_centos_6_6_x86_64_cv__14
  • KT_Organization_dev_centos_6_6_x86_64_comp_cv_51
  • KT_Organization_dev_centos_6_x86_64_cv__16
  • KT_Organization_dev_centos_6_x86_64_comp_cv_50
  • KT_Organization_dev_centos_6_x86_64_cv_19
  • KT_Organization_dev_centos_6_x86_64_default_composite_cv_26
  • KT_Organization_dev_centos_7_x86_64_cv__17
  • KT_Organization_dev_dell_cv_58
  • KT_Organization_dev_epel_6_x86_64_cv_27
  • KT_Organization_dev_katello_client_el5_x86_64_cv_46
  • KT_Organization_dev_katello_client_el6_x86_64_cv_47
  • KT_Organization_dev_katello_client_el7_x86_64_cv_48
  • KT_Organization_dev_katello_server_el6_x86_64_cv_72
  • KT_Organization_dev_puppet_cv_24
  • KT_Organization_dev_puppet_el5_x86_64_cv_42
  • KT_Organization_dev_puppet_el5_x86_64_cv_70
  • KT_Organization_dev_puppet_el6_x86_64_cv_30
  • KT_Organization_dev_puppet_rhel6_x86_64_cv_64
  • KT_Organization_dev_rhel_5_8_x86_64_cv_69
  • KT_Organization_dev_rhel_5_8_x86_64_cv_9
  • KT_Organization_dev_rhel_5_8_x86_64_comp_cv_54
  • KT_Organization_dev_rhel_6_4_x86_64_cv_6
  • KT_Organization_dev_rhel_6_4_x86_64_comp_cv_53
  • KT_Organization_dev_rhel_6_4_x86_64_comp_cv_62
  • KT_Organization_dev_rhel_6_6_x86_64_cv_60
  • KT_Organization_dev_rhel_6_6_x86_64_cv_7
  • KT_Organization_dev_rhel_6_6__x86_64_comp_cv_66
  • KT_Organization_dev_rhel_6_x86_64_cv_4
  • KT_Organization_dev_rhel_6_x86_64_cv_59
  • KT_Organization_dev_rhel_6_x86_64_comp_cv_52
  • KT_Organization_dev_rhel_6_x86_64_comp_cv_65
  • KT_Organization_dev_rhel_7_x86_64_cv_5
  • KT_Organization_Library_bobl_composite_cv_45
  • KT_Organization_Library_centos_6_5_x86_64_cv__15
  • KT_Organization_Library_centos_6_5_x86_64_comp_cv_56
  • KT_Organization_Library_centos_6_6_x86_64_cv__14
  • KT_Organization_Library_centos_6_6_x86_64_comp_cv_51
  • KT_Organization_Library_centos_6_x86_64_cv__16
  • KT_Organization_Library_centos_6_x86_64_comp_cv_50
  • KT_Organization_Library_centos_6_x86_64_cv_19
  • KT_Organization_Library_centos_6_x86_64_default_composite_cv_26
  • KT_Organization_Library_centos_7_x86_64_cv__17
  • KT_Organization_Library_centos_7_x86_64_comp_cv_57
  • KT_Organization_Library_dell_cv_58
  • KT_Organization_Library_epel_5_x86_64_cv_32
  • KT_Organization_Library_epel_6_x86_64_cv_27
  • KT_Organization_Library_epel_7_x86_64_28
  • KT_Organization_Library_katello_client_el5_x86_64_cv_46
  • KT_Organization_Library_katello_client_el6_x86_64_cv_47
  • KT_Organization_Library_katello_client_el7_x86_64_cv_48
  • KT_Organization_Library_katello_el6_x86_64_cv_72
  • KT_Organization_Library_puppet_cv_24
  • KT_Organization_Library_puppet_el5_x86_64_cv_42
  • KT_Organization_Library_puppet_el5_x86_64_cv_70
  • KT_Organization_Library_puppet_el6_x86_64_cv_30
  • KT_Organization_Library_puppet_rhel6_x86_64_cv_64
  • KT_Organization_Library_rhel_5_8_x86_64_cv_69
  • KT_Organization_Library_rhel_5_8_x86_64_cv_9
  • KT_Organization_Library_rhel_5_8_x86_64_comp_cv_54
  • KT_Organization_Library_rhel_5_x86_64_cv_3
  • KT_Organization_Library_rhel_6_4_x86_64_cv_6
  • KT_Organization_Library_rhel_6_4_x86_64_comp_cv_53
  • KT_Organization_Library_rhel_6_4_x86_64_comp_cv_62
  • KT_Organization_Library_rhel_6_6_x86_64_cv_7
  • KT_Organization_Library_rhel_6_6__x86_64_comp_cv_66
  • KT_Organization_Library_rhel_6_x86_64_cv_4
  • KT_Organization_Library_rhel_6_x86_64_cv_59
  • KT_Organization_Library_rhel_6_x86_64_comp_cv_52
  • KT_Organization_Library_rhel_6_x86_64_comp_cv_65
  • KT_Organization_Library_rhel_7_x86_64_cv_5
  • KT_Organization_Library_test_rhel_5_8_cv_67
  • KT_Organization_prod_centos_6_5_x86_64_cv__15
  • KT_Organization_prod_centos_6_5_x86_64_comp_cv_56
  • KT_Organization_prod_centos_6_6_x86_64_cv__14
  • KT_Organization_prod_centos_6_6_x86_64_comp_cv_51
  • KT_Organization_prod_centos_6_x86_64_cv__16
  • KT_Organization_prod_centos_6_x86_64_comp_cv_50
  • KT_Organization_prod_centos_6_x86_64_cv_19
  • KT_Organization_prod_centos_7_x86_64_cv__17
  • KT_Organization_prod_dell_cv_58
  • KT_Organization_prod_epel_5_x86_64_cv_34
  • KT_Organization_prod_epel_6_x86_64_cv_27
  • KT_Organization_prod_epel_7_x86_64_cv_33
  • KT_Organization_prod_hp_rhel_cv_40
  • KT_Organization_prod_katello_client_el5_x86_64_cv_46
  • KT_Organization_prod_katello_client_el6_x86_64_cv_47
  • KT_Organization_prod_katello_client_el7_x86_64_cv_48
  • KT_Organization_prod_katello_server_el6_x86_64_cv_72
  • KT_Organization_prod_puppet_cv_24
  • KT_Organization_prod_puppet_el5_x86_64_cv_42
  • KT_Organization_prod_puppet_el5_x86_64_cv_70
  • KT_Organization_prod_puppet_el6_x86_64_cv_30
  • KT_Organization_prod_puppet_rhel6_x86_64_cv_64
  • KT_Organization_prod_rhel_5_8_x86_64_cv_69
  • KT_Organization_prod_rhel_5_8_x86_64_cv_9
  • KT_Organization_prod_rhel_5_8_x86_64_comp_cv_54
  • KT_Organization_prod_rhel_6_4_x86_64_cv_6
  • KT_Organization_prod_rhel_6_4_x86_64_comp_cv_53
  • KT_Organization_prod_rhel_6_4_x86_64_comp_cv_62
  • KT_Organization_prod_rhel_6_6_x86_64_cv_60
  • KT_Organization_prod_rhel_6_6__x86_64_comp_cv_66
  • KT_Organization_prod_rhel_6_x86_64_cv_4
  • KT_Organization_prod_rhel_6_x86_64_cv_59
  • KT_Organization_prod_rhel_6_x86_64_comp_cv_65
  • KT_Organization_prod_rhel_7_x86_64_cv_5
  • KT_Organization_prod_vmware_el5_x86_64_cv_38
  • KT_Organization_prod_vmware_el6_x86_64_cv_39
  • KT_Organization_qa_centos_6_5_x86_64_cv__15
  • KT_Organization_qa_centos_6_5_x86_64_comp_cv_56
  • KT_Organization_qa_centos_6_6_x86_64_cv__14
  • KT_Organization_qa_centos_6_6_x86_64_comp_cv_51
  • KT_Organization_qa_centos_6_x86_64_cv__16
  • KT_Organization_qa_centos_6_x86_64_comp_cv_50
  • KT_Organization_qa_centos_6_x86_64_cv_19
  • KT_Organization_qa_centos_6_x86_64_default_composite_cv_26
  • KT_Organization_qa_centos_7_x86_64_cv__17
  • KT_Organization_qa_dell_cv_58
  • KT_Organization_qa_epel_6_x86_64_cv_27
  • KT_Organization_qa_hp_rhel_cv_40
  • KT_Organization_qa_katello_client_el5_x86_64_cv_46
  • KT_Organization_qa_katello_client_el6_x86_64_cv_47
  • KT_Organization_qa_katello_client_el7_x86_64_cv_48
  • KT_Organization_qa_katello_server_el6_x86_64_cv_72
  • KT_Organization_qa_puppet_cv_24
  • KT_Organization_qa_puppet_el5_x86_64_cv_42
  • KT_Organization_qa_puppet_el5_x86_64_cv_70
  • KT_Organization_qa_puppet_el6_x86_64_cv_30
  • KT_Organization_qa_puppet_rhel6_x86_64_cv_64
  • KT_Organization_qa_rhel_5_8_x86_64_cv_69
  • KT_Organization_qa_rhel_5_8_x86_64_cv_9
  • KT_Organization_qa_rhel_5_8_x86_64_comp_cv_54
  • KT_Organization_qa_rhel_6_4_x86_64_cv_6
  • KT_Organization_qa_rhel_6_4_x86_64_comp_cv_53
  • KT_Organization_qa_rhel_6_4_x86_64_comp_cv_62
  • KT_Organization_qa_rhel_6_6_x86_64_cv_60
  • KT_Organization_qa_rhel_6_6__x86_64_comp_cv_66
  • KT_Organization_qa_rhel_6_x86_64_cv_4
  • KT_Organization_qa_rhel_6_x86_64_cv_59
  • KT_Organization_qa_rhel_6_x86_64_comp_cv_52
  • KT_Organization_qa_rhel_6_x86_64_comp_cv_65
  • KT_Organization_qa_rhel_7_x86_64_cv_5
  • KT_Organization_qa_vmware_el5_x86_64_cv_38
  • KT_Organization_staging_centos_6_5_x86_64_cv__15
  • KT_Organization_staging_centos_6_5_x86_64_comp_cv_56
  • KT_Organization_staging_centos_6_6_x86_64_cv__14
  • KT_Organization_staging_centos_6_6_x86_64_comp_cv_51
  • KT_Organization_staging_centos_6_x86_64_cv__16
  • KT_Organization_staging_centos_6_x86_64_comp_cv_50
  • KT_Organization_staging_centos_6_x86_64_cv_19
  • KT_Organization_staging_centos_7_x86_64_cv__17
  • KT_Organization_staging_dell_cv_58
  • KT_Organization_staging_epel_5_x86_64_cv_34
  • KT_Organization_staging_epel_6_x86_64_cv_27
  • KT_Organization_staging_hp_rhel_cv_40
  • KT_Organization_staging_katello_client_el5_x86_64_cv_46
  • KT_Organization_staging_katello_client_el6_x86_64_cv_47
  • KT_Organization_staging_katello_client_el7_x86_64_cv_48
  • KT_Organization_staging_katello_server_el6_x86_64_cv_72
  • KT_Organization_staging_puppet_cv_24
  • KT_Organization_staging_puppet_el5_x86_64_cv_42
  • KT_Organization_staging_puppet_el5_x86_64_cv_70
  • KT_Organization_staging_puppet_el6_x86_64_cv_30
  • KT_Organization_staging_puppet_rhel6_x86_64_cv_64
  • KT_Organization_staging_rhel_5_8_x86_64_cv_69
  • KT_Organization_staging_rhel_5_8_x86_64_cv_9
  • KT_Organization_staging_rhel_5_8_x86_64_comp_cv_54
  • KT_Organization_staging_rhel_6_4_x86_64_cv_6
  • KT_Organization_staging_rhel_6_4_x86_64_comp_cv_53
  • KT_Organization_staging_rhel_6_4_x86_64_comp_cv_62
  • KT_Organization_staging_rhel_6_6_x86_64_cv_60
  • KT_Organization_staging_rhel_6_6__x86_64_comp_cv_66
  • KT_Organization_staging_rhel_6_x86_64_cv_4
  • KT_Organization_staging_rhel_6_x86_64_cv_59
  • KT_Organization_staging_rhel_6_x86_64_comp_cv_52
  • KT_Organization_staging_rhel_6_x86_64_comp_cv_65
  • KT_Organization_staging_rhel_7_x86_64_cv_5
  • KT_Organization_staging_vmware_el5_x86_64_cv_38
  • KT_Organization_staging_vmware_el6_x86_64_cv_39
  • production

#3 Updated by Eric Helms over 6 years ago

While investigating and looking at your data, I had one more question to help me, if I look at 'centos-6-x86_64-cv' for example -- was this a content view you deleted and re-created with the same name?

#4 Updated by Greg Koch over 6 years ago

I do believe that is one of the Content Views we had to re-create. After cleaning up the Puppet Envs, things got a little better, but we've created more Content Views (we now have 40 views as opposed to the 32 before) and thus more Puppet Envs (200 as opposed to the 183 we had after cleaning up old ones) and have noticed this error happening more often. We are unable to publish/promote more than 1 Content View at a time now because they both hit this step and hang/clobber each other. Repeated resumes eventually resolves the issue.

#6 Updated by Eric Helms over 6 years ago

  • Target version set to 67

#7 Updated by Justin Sherrill over 6 years ago

  • Bugzilla link set to 1195979

#8 Updated by Eric Helms over 6 years ago

  • Target version changed from 67 to 68

#10 Updated by Eric Helms over 6 years ago

  • Status changed from Need more information to Duplicate

#11 Updated by Eric Helms over 6 years ago

  • Is duplicate of Bug #9647: Publish/Promotion times in Satellite 6 growing after each publish/promotion added

#12 Updated by Eric Helms over 6 years ago

  • Legacy Backlogs Release (now unused) deleted (23)

#13 Updated by Checheta Yan almost 6 years ago

Spam removed by Redmine administrator

#14 Updated by Eric Helms over 5 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF