Project

General

Profile

Bug #900

searching on time is not correct

Added by Paul Kelly over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Search
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

I am guessing that there is an issue with timezones when doing a search. If I select "hosts - active" then the search generates "last_report > "35 minutes ago" and (status.applied > 0 or status.restarted > 0)". There are no hosts returned with this search. If I change this to "last_report > "95 minutes ago" and (status.applied > 0 or status.restarted > 0)" then I get the expected, huge, list. Of course I could be wrong and this may not be an issue with timezones. . . .


Related issues

Is duplicate of Foreman - Bug #938: Editing out_of_sync bookmark results in a page not foundDuplicate2011-05-24

Associated revisions

Revision 1baed2e3 (diff)
Added by Amos Benari over 9 years ago

fixes #900 - search by "x minutes ago" and the charts in show host

Signed-off-by: Amos Benari <>

History

#1 Updated by Ohad Levy over 9 years ago

Paul, can you double check that your foreman host time is synced correctly?

does it happen with all time stamp fields? (such as installed_at)

#2 Updated by Amos Benari over 9 years ago

  • Assignee set to Amos Benari

#3 Updated by Ohad Levy over 9 years ago

  • Target version set to 0.3

#4 Updated by Amos Benari over 9 years ago

  • Status changed from New to Ready For Testing
  • % Done changed from 0 to 100

#5 Updated by Ohad Levy over 9 years ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF