Project

General

Profile

Bug #9009

"No Context" message missing in 2.1RC

Added by Ashton Davis almost 6 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Previously, when there was no context selected (i.e. org), there would be a message stating "permission denied" or something to that effect if I tried to look at products or anything else org-specific.
After the 2.1RC upgrade, if I happen to try to open one of those pages without a context, It just sits at the "Searching" status indefinitely.

This error message was misleading before as well, as it wasn't a permissions issue, but a lack of context. There should probably be a check on these pages for whether or not an organization is selected, and if not, return a message saying this data is only available within orgs.


Related issues

Is duplicate of Katello - Bug #8387: No feedback from Katello that there's no organization selectedClosed2014-11-13

History

#1 Updated by Eric Helms almost 6 years ago

  • Is duplicate of Bug #8387: No feedback from Katello that there's no organization selected added

#2 Updated by Eric Helms almost 6 years ago

  • Status changed from New to Duplicate
  • Triaged changed from No to Yes

#3 Updated by Eric Helms over 4 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF