Project

General

Profile

Bug #9172

katello-installer failed with /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[FQDN]: Could not evaluate: Could not load data from https://FQDN

Added by Sachin Ghai over 7 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Recent katello-installer on rhel7/66 in nightly(katello+foreman) failed with error:

[ INFO 2015-01-30 01:23:43 verbose] Executing hooks in group post
Something went wrong! Check the log for ERROR-level output
The full log is at /var/log/katello-installer/katello-installer.log
[ INFO 2015-01-30 01:23:43 verbose] All hooks in group post finished
[ERROR 2015-01-30 01:23:43 verbose] Repeating errors encountered during run:
[ERROR 2015-01-30 01:23:43 verbose] /usr/share/foreman/script/foreman-config -k ssl_ca_file -v '/etc/foreman/proxy_ca.pem' -k ssl_certificate -v '/etc/foreman/client_cert.pem' -k ssl_priv_key -v '/etc/foreman/client_key.pem' returned 1 instead of one of [0]
[ERROR 2015-01-30 01:23:43 verbose] /Stage[main]/Certs::Foreman/Exec[foreman_certs_config]/returns: change from notrun to 0 failed: /usr/share/foreman/script/foreman-config -k ssl_ca_file -v '/etc/foreman/proxy_ca.pem' -k ssl_certificate -v '/etc/foreman/client_cert.pem' -k ssl_priv_key -v '/etc/foreman/client_key.pem' returned 1 instead of one of [0]
[ERROR 2015-01-30 01:23:43 verbose] /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[qe-foreman-rhel7.usersys.redhat.com]: Could not evaluate: Could not load data from https://qe-foreman-rhel7.usersys.redhat.com
[ERROR 2015-01-30 01:23:43 verbose] /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[qe-foreman-rhel7.usersys.redhat.com]: Failed to call refresh: Could not load data from https://qe-foreman-rhel7.usersys.redhat.com
[ERROR 2015-01-30 01:23:43 verbose] /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[qe-foreman-rhel7.usersys.redhat.com]: Could not load data from https://qe-foreman-rhel7.usersys.redhat.com
[

katello-installer.log katello-installer.log 992 KB Sachin Ghai, 01/30/2015 01:35 AM

Related issues

Is duplicate of foreman-tasks - Bug #9171: Can't migrate clean database if foreman_tasks presentClosed2015-01-29

History

#1 Updated by Eric Helms over 7 years ago

  • Project changed from Foreman to Katello
  • Category deleted (47)
  • Status changed from New to Duplicate
  • Triaged set to Yes

#2 Updated by Eric Helms over 7 years ago

  • Is duplicate of Bug #9171: Can't migrate clean database if foreman_tasks present added

#3 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF