Project

General

Profile

Bug #9202

katello-installer should use systemd instead of chkconfig for all services on rhel7

Added by dustin tsang over 5 years ago. Updated almost 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Installer
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1187206
Description of problem:
See bz: https://bugzilla.redhat.com/show_bug.cgi?id=1187014

Recent nightly installer failed with following error on rhel7.

[ERROR 2015-01-29 02:24:41 verbose] Could not enable postgresql: Execution of '/sbin/chkconfig --add postgresql' returned 1: error reading information on service postgresql: No such file or directory
[ERROR 2015-01-29 02:24:41 verbose] /Stage[main]/Postgresql::Server::Service/Service[postgresqld]/enable: change from false to true failed: Could not enable postgresql: Execution of '/sbin/chkconfig --add postgresql' returned 1: error reading information on service postgresql: No such file or directory
[ERROR 2015-01-29 02:24:41 verbose] Could not enable mongod: Execution of '/sbin/chkconfig --add mongod' returned 1: error reading information on service mongod: No such file or directory
[ERROR 2015-01-29 02:24:41 verbose] /Stage[main]/Mongodb::Server::Service/Service[mongodb]/enable: change from false to true failed: Could not enable mongod: Execution of '/sbin/chkconfig --add mongod' returned 1: error reading information on service mongod: No such file or directory
[ERROR 2015-01-29 02:24:41 verbose] Could not enable puppet: Execution of '/sbin/chkconfig --add puppet' returned 1: error reading information on service puppet: No such file or directory
[ERROR 2015-01-29 02:24:41 verbose] /Stage[main]/Puppet::Agent::Service/Service[puppet]/enable: change from false to true failed: Could not enable puppet: Execution of '/sbin/chkconfig --add puppet' returned 1: error reading information on service puppet: No such file or directory
[ERROR 2015-01-29 02:24:41 verbose] Could not enable foreman-proxy: Execution of '/sbin/chkconfig --add foreman-proxy' returned 1: error reading information on service foreman-proxy: No such file or directory
[ERROR 2015-01-29 02:24:41 verbose] /Stage[main]/Foreman_proxy::Service/Service[foreman-proxy]/enable: change from false to true failed: Could not enable foreman-proxy: Execution of '/sbin/chkconfig --add foreman-proxy' returned 1: error reading information on

Here you can see a bunch of services like foreman-proxy, mongod, puppet, postgresql using chkconfig. It should be replaced by systemd.

Version-Release number of selected component (if applicable):
nightly rhel7

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Here you can see a bunch of services like foreman-proxy, mongod, puppet, postgresql using chkconfig. It should be replaced by systemd.

Additional info:


Related issues

Has duplicate Katello - Bug #9163: katello-installer failed on rhel7 with error: Could not enable postgresql: Execution of '/sbin/chkconfig --add postgresql' returned 1:Closed2015-01-29
Is duplicate of Katello - Bug #8478: MongoDB fails to start with a RHEL 7 systemClosed2014-11-21

History

#1 Updated by dustin tsang over 5 years ago

  • Has duplicate Bug #9163: katello-installer failed on rhel7 with error: Could not enable postgresql: Execution of '/sbin/chkconfig --add postgresql' returned 1: added

#2 Updated by dustin tsang over 5 years ago

  • Status changed from New to Closed

fixed in #8478

#3 Updated by dustin tsang over 5 years ago

  • Is duplicate of Bug #8478: MongoDB fails to start with a RHEL 7 system added

#4 Updated by dustin tsang over 5 years ago

tested seems to be fixed by #8478.
installer: output https://gist.github.com/3dc986eb9ce41dc32dc8
(for katello-installer @ 0c126a368f2e37755aa0d2fada2c54f51ea33f09)

#5 Updated by Eric Helms over 5 years ago

  • Status changed from Closed to Duplicate
  • Triaged changed from No to Yes

#6 Updated by Eric Helms almost 4 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF