Project

General

Profile

Bug #9237

Publish content view version failing on several dynflow tasks

Added by Primoz Fonda almost 5 years ago. Updated 3 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Orchestration
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Use case:
- create several repositories
- start syncing them
- sync paused due to disk space issues.
- after adding disk space, sync jobs restarted
- meanwhile created new version of a content view containing the repos above
- Publish content view task fails: cannot cancel parent tasks in GUI (browser timeouts)
- Dynaflow view shows a lot of tasks paused or in error. Have to skip/cancel one at the time, reload, resume workflow.

Is there a way of cancelling/removing entire workflow? Like a clean up procedure?

History

#1 Updated by Ivan Necas almost 5 years ago

  • Tracker changed from Support to Bug
  • Project changed from foreman-tasks to Katello
  • Triaged set to No

Moving to Katello project, as the issue is not in the realm of the foreman-tasks itself.

As per the canclelling the whole workflow, it's not good idea in general (as the
tasks not being performed were there for a reason, so their skipping
might lead to more serious /and unpredicable/ issues later: it's just postponing
the issue). One can do 'Force stop' and the task which unlocks the touched resources
so that other tasks can run against it without the lock issue

#2 Updated by Eric Helms almost 5 years ago

  • Category set to Orchestration
  • Legacy Backlogs Release (now unused) set to 23
  • Triaged changed from No to Yes

#3 Updated by Eric Helms over 4 years ago

  • Legacy Backlogs Release (now unused) changed from 23 to 31

#4 Updated by Eric Helms over 4 years ago

  • Legacy Backlogs Release (now unused) deleted (31)

#5 Updated by Eric Helms almost 4 years ago

  • Legacy Backlogs Release (now unused) set to 86

#6 Updated by Eric Helms over 3 years ago

  • Legacy Backlogs Release (now unused) changed from 86 to 114

#7 Updated by John Mitsch 3 months ago

  • Target version deleted (Katello Backlog)
  • Status changed from New to Rejected

Thanks for reporting this issue. This issue was created over 4 years ago and hasn't seen an update in 1 year. We are closing this in an effort to keep a realistic backlog. Please open up a new issue that includes a link to this issue if you feel this still needs to be addressed. We can then triage the new issue and reassess.

Also available in: Atom PDF