Project

General

Profile

Bug #9243

katello-installer failing on RHEL-7

Added by Brad Buckingham over 7 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
High
Assignee:
Category:
Installer
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Running katello-installer on RHEL-7 is resulting in errors like the ones below. Running it a second time also encounters as well as re-running with --reset.

Attached also is the full katello-installer.log.

Output errors:

Installing Debug: /Stage[main]/Certs::Candlepin/Exec[create c [99%] qpid-config --ssl-certificate /etc/pki/katello/certs/java-client.crt --ssl-key /etc/pki/katello/private/java-client.key -b 'amqps://rhel7-katello-nightly.test:5671' add exchange topic event --durable returned 1 instead of one of [0]
/Stage[main]/Certs::Candlepin/Exec[create candlepin qpid exchange]/returns: change from notrun to 0 failed: qpid-config --ssl-certificate /etc/pki/katello/certs/java-client.crt --ssl-key /etc/pki/katello/private/java-client.key -b 'amqps://rhel7-katello-nightly.test:5671' add exchange topic event --durable returned 1 instead of one of [0]
Installing Debug: /Stage[main]/Certs::Candlepin/Exec[create c [99%] /Stage[main]/Certs::Candlepin/Exec[create candlepin qpid exchange]: Failed to call refresh: qpid-config --ssl-certificate /etc/pki/katello/certs/java-client.crt --ssl-key /etc/pki/katello/private/java-client.key -b 'amqps://rhel7-katello-nightly.test:5671' add exchange topic event --durable returned 1 instead of one of [0]
/Stage[main]/Certs::Candlepin/Exec[create candlepin qpid exchange]: qpid-config --ssl-certificate /etc/pki/katello/certs/java-client.crt --ssl-key /etc/pki/katello/private/java-client.key -b 'amqps://rhel7-katello-nightly.test:5671' add exchange topic event --durable returned 1 instead of one of [0]
Installing Notice: /Stage[main]/Certs::Candlepin/Exec[import [99%] Installing Debug: /Stage[main]/Certs::Candlepin/Exec[import c [99%] Installing Notice: /Stage[main]/Certs::Candlepin/Exec[import [99%] Installing Notice: /Stage[main]/Foreman::Database/Foreman::Ra [99%] Installing Notice: /Stage[main]/Foreman::Database/Foreman::Ra [99%] Installing Notice: /Stage[main]/Foreman::Plugin::Bootdisk/For [99%] /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[rhel7-katello-nightly.test]: Failed to call refresh: Could not load data from https://rhel7-katello-nightly.test
/Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[rhel7-katello-nightly.test]: Could not load data from https://rhel7-katello-nightly.test
Installing Debug: Stored state in 0.11 seconds [99%] Installing Done [100%]Installing Done [100%] []

katello-installer.log katello-installer.log 1.36 MB Brad Buckingham, 02/05/2015 02:39 PM

Related issues

Is duplicate of Katello - Bug #9364: Install katello-deploy on Centos 7Closed2015-02-12

Associated revisions

Revision c09a1212 (diff)
Added by Eric Helms about 7 years ago

Fixes #9243: Ensure service_wait is called on systems with systemd.

For systems that use systemd, such as EL7, the command is no longer
service but systemctl. This specific command needs to be set as the
provider command so that service_wait is invoked for systemd.

Revision cdb706d7
Added by Eric D Helms about 7 years ago

Merge pull request #8 from ehelms/fixes-9243

Fixes #9243: Ensure service_wait is called on systems with systemd.

History

#1 Updated by Eric Helms over 7 years ago

  • Assignee set to Eric Helms
  • Target version set to 66
  • Legacy Backlogs Release (now unused) set to 33
  • Triaged changed from No to Yes

#2 Updated by Eric Helms about 7 years ago

  • Is duplicate of Bug #9364: Install katello-deploy on Centos 7 added

#3 Updated by Eric Helms about 7 years ago

  • Status changed from New to Duplicate

#4 Updated by Eric Helms about 7 years ago

  • Legacy Backlogs Release (now unused) deleted (33)

#5 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF