Project

General

Profile

Bug #9316

Puppet Environment Deletion allowed even when content view still exists

Added by Justin Sherrill over 7 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Hosts
Target version:
Difficulty:
easy
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Currently we allow puppet environments to be deleted, even when the content view version still is published into a lifecycle environment. We should restrict this.


Related issues

Related to Katello - Bug #9317: Content View remove/deletion fails Closed2015-02-10
Is duplicate of Katello - Bug #10460: Prevent puppet environments from being deleted when produced by a content viewRejected

History

#1 Updated by Justin Sherrill over 7 years ago

  • Legacy Backlogs Release (now unused) changed from 23 to 33

#2 Updated by Justin Sherrill over 7 years ago

  • Related to Bug #9317: Content View remove/deletion fails added

#3 Updated by Justin Sherrill about 7 years ago

  • Legacy Backlogs Release (now unused) changed from 33 to 23

#4 Updated by Eric Helms about 7 years ago

  • Target version set to 67

#5 Updated by Eric Helms about 7 years ago

  • Legacy Backlogs Release (now unused) changed from 23 to 31

#6 Updated by Eric Helms about 7 years ago

  • Target version changed from 67 to 68

#7 Updated by Eric Helms about 7 years ago

  • Target version deleted (68)

#8 Updated by Eric Helms almost 7 years ago

  • Status changed from New to Duplicate
  • Legacy Backlogs Release (now unused) deleted (31)

#9 Updated by Eric Helms almost 7 years ago

  • Is duplicate of Bug #10460: Prevent puppet environments from being deleted when produced by a content view added

#10 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF