Project

General

Profile

Actions

Bug #9320

closed

Can't create host using VMWare compute resource

Added by Alexandre Barth about 9 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Category:
Compute resources - VMware
Target version:
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

When i want to provision a host in my VMWare compute resource using Foreman 1.8.0 develop, all options in the vm tab are greyed out except datastore selection.
Once submiting, host creation fails with the following error : 'cluster is required for this operation' though i'm using a vcenter server with clusters.


Related issues 3 (0 open3 closed)

Related to Foreman - Bug #9152: Provisioning new oVirt VM's failsResolvedTomáš Strachota01/28/2015Actions
Related to Foreman - Refactor #8661: fix some problematic styling issues in the vm form partials.ClosedTom Caspy12/11/2014Actions
Blocked by Foreman - Bug #9480: Fix multiple NICs integration with compute profilesClosedTomáš Strachota02/20/2015Actions
Actions #1

Updated by Dominic Cleal about 9 years ago

  • Related to Bug #9152: Provisioning new oVirt VM's fails added
Actions #2

Updated by Dominic Cleal about 9 years ago

  • Related to Refactor #8661: fix some problematic styling issues in the vm form partials. added
Actions #3

Updated by Dominic Cleal about 9 years ago

  • Category set to Compute resources - VMware

This looks very similar to #9152, maybe it's the same, but probably caused by #8661.

Actions #4

Updated by Dominic Cleal about 9 years ago

  • translation missing: en.field_release set to 28
Actions #5

Updated by Tom Caspy about 9 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Tom Caspy
  • Pull request https://github.com/theforeman/foreman/pull/2150 added
  • Pull request deleted ()
Actions #6

Updated by Alexandre Barth about 9 years ago

It is now working like a charm, thank you for the fix :)

Actions #7

Updated by Alexandre Barth about 9 years ago

Now i'm facing this issue #9430

Actions #8

Updated by Dominic Cleal almost 9 years ago

  • Blocked by Bug #9480: Fix multiple NICs integration with compute profiles added
Actions #9

Updated by Dominic Cleal almost 9 years ago

  • Status changed from Ready For Testing to Resolved
  • Assignee changed from Tom Caspy to Tomáš Strachota

I believe this issue has been resolved via #9480 instead, which will be available in nightly builds soon. Please re-open if you see it in nightlies or 1.8.0-RC1, thanks!

Actions

Also available in: Atom PDF