Project

General

Profile

Bug #9354

foreman-rake katello:upgrades:2.1:import_errata fails: wrong number of arguments

Added by Mark Versfeld almost 8 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Upgrades
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Upgrade to 2.1 fails at import_errata

foreman-rake katello:upgrades:2.1:import_errata --trace
  • Invoke katello:upgrades:2.1:import_errata (first_time)
  • Invoke environment (first_time)
  • Execute environment
  • Execute katello:upgrades:2.1:import_errata
    Importing Errata
    Updating Content Host Repositories
    Updating Content Host Repositories
    rake aborted!
    wrong number of arguments
    /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.1.0/lib/katello/tasks/upgrades/2.1/import_errata.rake:8:in `system'
    /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.1.0/lib/katello/tasks/upgrades/2.1/import_errata.rake:8:in `error'
    /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.1.0/lib/katello/tasks/upgrades/2.1/import_errata.rake:33:in `rescue in block (5 levels) in <top (required)>'
    /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.1.0/lib/katello/tasks/upgrades/2.1/import_errata.rake:30:in `block (5 levels) in <top (required)>'
    /opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/relation/batches.rb:21:in `block (2 levels) in find_each'
    /opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/relation/batches.rb:21:in `each'
    /opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/relation/batches.rb:21:in `block in find_each'
    /opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/relation/batches.rb:72:in `find_in_batches'
    /opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/relation/batches.rb:20:in `find_each'
    /opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/querying.rb:8:in `find_each'
    /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.1.0/lib/katello/tasks/upgrades/2.1/import_errata.rake:29:in `block (4 levels) in <top (required)>'
    /opt/rh/ruby193/root/usr/share/ruby/rake/task.rb:205:in `call'
    /opt/rh/ruby193/root/usr/share/ruby/rake/task.rb:205:in `block in execute'
    /opt/rh/ruby193/root/usr/share/ruby/rake/task.rb:200:in `each'
    /opt/rh/ruby193/root/usr/share/ruby/rake/task.rb:200:in `execute'
    /opt/rh/ruby193/root/usr/share/ruby/rake/task.rb:158:in `block in invoke_with_call_chain'
    /opt/rh/ruby193/root/usr/share/ruby/monitor.rb:211:in `mon_synchronize'
    /opt/rh/ruby193/root/usr/share/ruby/rake/task.rb:151:in `invoke_with_call_chain'
    /opt/rh/ruby193/root/usr/share/ruby/rake/task.rb:144:in `invoke'
    /opt/rh/ruby193/root/usr/share/ruby/rake/application.rb:116:in `invoke_task'
    /opt/rh/ruby193/root/usr/share/ruby/rake/application.rb:94:in `block (2 levels) in top_level'
    /opt/rh/ruby193/root/usr/share/ruby/rake/application.rb:94:in `each'
    /opt/rh/ruby193/root/usr/share/ruby/rake/application.rb:94:in `block in top_level'
    /opt/rh/ruby193/root/usr/share/ruby/rake/application.rb:133:in `standard_exception_handling'
    /opt/rh/ruby193/root/usr/share/ruby/rake/application.rb:88:in `top_level'
    /opt/rh/ruby193/root/usr/share/ruby/rake/application.rb:66:in `block in run'
    /opt/rh/ruby193/root/usr/share/ruby/rake/application.rb:133:in `standard_exception_handling'
    /opt/rh/ruby193/root/usr/share/ruby/rake/application.rb:63:in `run'
    /opt/rh/ruby193/root/usr/bin/rake:32:in `<main>'
    caused by: (RestClient::ResourceNotFound) 404 Resource Not Found
    /opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/abstract_response.rb:48:in `return!'
    /opt/rh/ruby193/root/usr/share/gems/gems/runcible-1.3.0/lib/runcible/base.rb:92:in `block in get_response'
    /opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:228:in `call'
    /opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:228:in `process_result'
    /opt/rh/ruby193/root/usr/share/gems/gems/rbovirt-0.0.29/lib/restclient_ext/request.rb:50:in `block in transmit'
    /opt/rh/ruby193/root/usr/share/ruby/net/http.rb:746:in `start'
    /opt/rh/ruby193/root/usr/share/gems/gems/rbovirt-0.0.29/lib/restclient_ext/request.rb:44:in `transmit'
    /opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:64:in `execute'
    /opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:33:in `execute'
    /opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/resource.rb:51:in `get'
    /opt/rh/ruby193/root/usr/share/gems/gems/runcible-1.3.0/lib/runcible/base.rb:91:in `get_response'
    /opt/rh/ruby193/root/usr/share/gems/gems/runcible-1.3.0/lib/runcible/base.rb:82:in `call'
    /opt/rh/ruby193/root/usr/share/gems/gems/runcible-1.3.0/lib/runcible/resources/consumer.rb:106:in `retrieve_bindings'
    /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.1.0/app/models/katello/glue/pulp/consumer.rb:35:in `bindings'
    /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.1.0/app/models/katello/glue/pulp/consumer.rb:45:in `pulp_bound_yum_repositories'
    /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.1.0/lib/katello/tasks/upgrades/2.1/import_errata.rake:17:in `update_system_repositories'
    /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.1.0/lib/katello/tasks/upgrades/2.1/import_errata.rake:31:in `block (5 levels) in <top (required)>'
    ... skipped 25 lines
    Tasks: TOP => katello:upgrades:2.1:import_errata

Associated revisions

Revision bf6ec73c (diff)
Added by Justin Sherrill almost 8 years ago

fixes #9354 - fixing error with import_errata rake task

Revision d21474bf
Added by Justin Sherrill almost 8 years ago

Merge pull request #5173 from jlsherrill/9354

fixes #9354 - fixing error with import_errata rake task

History

#1 Updated by Dominic Cleal almost 8 years ago

  • Project changed from Foreman to Katello
  • Triaged set to No

#2 Updated by Stephen Benjamin almost 8 years ago

  • Status changed from New to Need more information

Thanks for the report, can you supply a `foreman-debug`? That would help narrow down the problem.

You can attach it here as a private attachment, or just say yes to uploading (and please provide the file name here after).

#3 Updated by Eric Helms almost 8 years ago

  • Category set to Upgrades
  • Target version set to 66
  • Legacy Backlogs Release (now unused) set to 33
  • Triaged changed from No to Yes

#4 Updated by Eric Helms almost 8 years ago

  • Legacy Backlogs Release (now unused) changed from 33 to 34

#5 Updated by Eric Helms almost 8 years ago

  • Target version changed from 66 to 67

#6 Updated by Mark Versfeld almost 8 years ago

uploaded foreman-debug-7YlTl.tar.xz

all client nodes are running on a VMWare ESX cluster, so depending on the load they move around over several ESX hosts

#7 Updated by Eric Helms almost 8 years ago

  • Target version changed from 67 to 68

#8 Updated by Stephen Benjamin almost 8 years ago

I'd guess you have some partially deleted content hosts, which would probably explain the 404 error in the traceback, as well all the errors I see in foreman/production.log.

If you run this first:
foreman-rake katello:clean_backend_objects

You can try the import again and it should work.

#9 Updated by Justin Sherrill almost 8 years ago

  • Legacy Backlogs Release (now unused) changed from 34 to 23

#10 Updated by Eric Helms almost 8 years ago

  • Target version deleted (68)

#11 Updated by The Foreman Bot almost 8 years ago

  • Status changed from Need more information to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5173 added
  • Pull request deleted ()

#12 Updated by Justin Sherrill almost 8 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF