Project

General

Profile

Bug #9383

content host reported by virt-who does not coincide with content host of hypervisor

Added by Thomas McKay over 4 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1169390
Description of problem:
We are running RHEV with RHEL hosts as hypervisors. The RHEL hosts are registered in the Satellite 6, so they have associated content_host records named after their host names.
When connecting virt-who to probe this RHEV installation, virt-who will create an additional set of content_hosts, this time named with a UUID. This second set of content hosts should in my opinion not be created but virt-who should rather fold in it's findings into the existing content_hosts.

Version-Release number of selected component (if applicable):
Satellite-6.0.6 on RHEL7

How reproducible:
Every time

Steps to Reproduce:
1. Register a RHEL host acting as a RHEV hypervisor into a satellite 6
2. Enable virt-who
3. Do note how an extra content host has shown up.

Expected results:
virt-who should add it's findings into the already existing content host


Related issues

Blocks Katello - Tracker #8059: Virtualization host-to-guestNew2014-10-23

History

#1 Updated by Thomas McKay over 4 years ago

#2 Updated by Eric Helms over 4 years ago

  • Legacy Backlogs Release (now unused) set to 31
  • Triaged changed from No to Yes

#3 Updated by Eric Helms over 4 years ago

  • Legacy Backlogs Release (now unused) deleted (31)

#4 Updated by Eric Helms over 3 years ago

  • Legacy Backlogs Release (now unused) set to 114

#5 Updated by Daniel Lobato Garcia over 2 years ago

  • Status changed from New to Closed

Closed downstream

Also available in: Atom PDF