Project

General

Profile

Bug #9429

user shouldn't be allowed to create alias and bond interfaces without specifying identifer

Added by Marek Hulán over 7 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Network
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1191953
Description of problem:
I can create alias and bond interfaces without specifying identifier. I think its required to link the virtual interface with the physical one.

If we don't pass identifier then I think it won't be configured on provisioned host via config template.

Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-6-20150210.0
Sat6.1.0 beta snap2

How reproducible:
always

Steps to Reproduce:
1. Add_interface of type Bond and alias
2.
3.

Actual results:
Alias and bond Interfaces can be created without interface identifier

Expected results:
User should get validation error as identifier are required for linking purpose.

Additional info:

Associated revisions

Revision 4feb1576 (diff)
Added by Marek Hulán over 7 years ago

Fixes #9429 - identifier is required for Alias and VLAN

History

#1 Updated by Marek Hulán over 7 years ago

  • Category set to Network
  • Status changed from New to Assigned

#2 Updated by Marek Hulán over 7 years ago

Actually identifier should be required only for VLAN/Alias

#3 Updated by The Foreman Bot over 7 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2177 added
  • Pull request deleted ()

#4 Updated by Marek Hulán over 7 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Dominic Cleal over 7 years ago

  • Legacy Backlogs Release (now unused) set to 28

Also available in: Atom PDF