Project

General

Profile

Actions

Bug #9444

closed

Firebug raises: "NetworkError: 404 Not Found" on selecting the 'Domain' from "New_Host_group --> Network" tab

Added by Bryan Kearney over 9 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1191849
Description of problem:
Firebug raises: "NetworkError: 404 Not Found" on selecting the 'Domain' from "New_Host_group --> Network" tab

--
"NetworkError: 404 Not Found - https://dhcp201-167.englab.pnq.redhat.com/hostgroups/current_parameters"
"NetworkError: 404 Not Found - https://dhcp201-167.englab.pnq.redhat.com/hostgroups/domain_selected"
--

Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-6-20150210.0
Sat6.1.0 beta snap2

How reproducible:
always

Steps to Reproduce:
1. Go to "configure" --> Host Group --> New Host Group --> Network
2. select domain from dropdown
a) select the domain name from drop down (make sure domain is already created one)
b) Now select the blank line from drop down

Actual results:
production.log:

Processing by HostgroupsController#current_parameters as /*
Parameters: {"hostgroup_id"=>"null", "hostgroup_parent_id"=>"undefined"}
Rendered common/404.html.erb within layouts/application (1.2ms)
Rendered layouts/base.html.erb (1.4ms)
Completed 404 Not Found in 22ms (Views: 6.1ms | ActiveRecord: 1.9ms)
Processing by HostgroupsController#domain_selected as */

Parameters: {"domain_id"=>""}
Completed 404 Not Found in 13ms (ActiveRecord: 1.6ms)

Expected results:
no error should be raised neither in production.log nor in firebug console

Additional info:


Related issues 1 (0 open1 closed)

Related to Foreman - Bug #9461: undefined method domain_selected() when selecting Host group domain/subnetClosedTomer Brisker02/19/2015Actions
Actions #1

Updated by Dominic Cleal over 9 years ago

  • Category set to Web Interface
  • Assignee deleted (Ohad Levy)
  • Priority changed from Normal to Low

Could be re-evaluated after #9461, likely to become invalid.

Actions #2

Updated by Tomer Brisker over 9 years ago

  • Related to Bug #9461: undefined method domain_selected() when selecting Host group domain/subnet added
Actions #3

Updated by Dominic Cleal over 9 years ago

The domain_selected part seems to be invalid now, but a 404 will remain on the current_parameters call when the Puppet environment is selected.. not that it matters much.

Actions #4

Updated by Tomer Brisker over 9 years ago

  • Status changed from New to Assigned
  • Assignee set to Tomer Brisker
  • Priority changed from Low to Normal
Actions #5

Updated by The Foreman Bot over 9 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2236 added
  • Pull request deleted ()
Actions #6

Updated by Dominic Cleal over 9 years ago

  • Translation missing: en.field_release set to 35
Actions #7

Updated by Anonymous over 9 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF