Project

General

Profile

Bug #9447

Repeating error messages when adding a new organization or location

Added by Bryan Kearney about 4 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1191248
Description of problem:
Creating a New Organization: Leaving Name and Label blank results in error strings of "can't be blank, can't be blank, and must contain at least 1 character" and "can't be blank, can't be blank, cannot contain characters other than ascii alpha numerals, '_', '-'. , and must contain at least 1 character" SS #516 Also duplicates the message when an org name is already in use "has already been taken and has already been taken"

Version-Release number of selected component (if applicable):
6.0.7

How reproducible:
N/A

Steps to Reproduce:
1. Create a new organization and leave fields blank
2. Click Submit
3. Repeating error messages appear

Actual results:
Repeating error messages for blank fields.

Expected results:
Single error message.

Additional info:
Screen shot attached.

Associated revisions

Revision a1cb786b (diff)
Added by Justin Sherrill over 3 years ago

Fixes #9447 - stop validating org name

and stop checking label existence twice

Revision eb38893f
Added by Justin Sherrill over 3 years ago

Merge pull request #5612 from jlsherrill/9447

Fixes #9447 - stop validating org name

History

#1 Updated by Dominic Cleal about 4 years ago

  • Project changed from Foreman to Katello
  • Assignee deleted (Ohad Levy)
  • Triaged set to No

Cannot reproduce the validation errors on the name, likely fixed (though I don't know which version the reporter is using).

Moving to Katello as that adds the label field for verification of a fix there.

#2 Updated by Eric Helms about 4 years ago

  • Target version set to 66
  • Legacy Backlogs Release (now unused) set to 23
  • Triaged changed from No to Yes

#3 Updated by Eric Helms about 4 years ago

  • Target version changed from 66 to 67

#4 Updated by Eric Helms about 4 years ago

  • Legacy Backlogs Release (now unused) changed from 23 to 31

#5 Updated by Eric Helms about 4 years ago

  • Target version changed from 67 to 68

#6 Updated by Eric Helms almost 4 years ago

  • Target version deleted (68)

#7 Updated by Stephen Benjamin over 3 years ago

  • Legacy Backlogs Release (now unused) changed from 31 to 70

#8 Updated by Justin Sherrill over 3 years ago

  • Assignee set to Justin Sherrill

#9 Updated by The Foreman Bot over 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5612 added

#10 Updated by Justin Sherrill over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF