Project

General

Profile

Feature #9481

As a user, I should be able to set per repository proxy settings.

Added by Andreas Pfaffeneder over 7 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Currently the proxy-settings have to be setup while doing the installation of foreman/katello/Satellite 6.

These proxy-settings currently are global, i.e. causing all repo-actions to be done via the configured proxy. This causes problems, when there are yum repositories in a internal network which cannot be accessed via proxy because it is put into a dmz.

To work around the problem, it would be handy to blacklist domains/hosts from being accessed via the proxy:

blacklist could look like:
*.internal.domain or
10.13.0.7


Related issues

Is duplicate of Katello - Feature #5280: As a user I want to be able to specify per org, per product and per repository proxy configurationRejected

History

#1 Updated by Dominic Cleal over 7 years ago

  • Project changed from Foreman to Katello
  • Triaged set to No

#3 Updated by Eric Helms over 7 years ago

  • Status changed from New to Need more information
  • Target version set to 67
  • Legacy Backlogs Release (now unused) set to 31
  • Triaged changed from No to Yes

Blacklisting hosts would have to be a feature in Pulp since it handles synxing. However, Pulp does support per repo proxy settings. Would that feature solve the issue?

#4 Updated by Andreas Pfaffeneder over 7 years ago

This would solve the problem.

#5 Updated by Eric Helms over 7 years ago

  • Subject changed from Proxy-Settings should support blacklisting to As a user, I should be able to set per repository proxy settings.

#6 Updated by Eric Helms over 7 years ago

  • Target version changed from 67 to 68

#7 Updated by Eric Helms about 7 years ago

  • Target version deleted (68)

#8 Updated by Stephen Benjamin about 7 years ago

  • Bugzilla link set to 1132980

#9 Updated by Stephen Benjamin about 7 years ago

@Eric, I think so!

It seems you can specify the proxy at the time of repo creation instead of yum_importer.json.  If we did that, then the user could have a check box to turn off the proxy

http://pulp-rpm-user-guide.readthedocs.org/en/latest/recipes.html#configure-proxy

#10 Updated by Eric Helms about 7 years ago

  • Status changed from Need more information to Duplicate
  • Legacy Backlogs Release (now unused) deleted (31)

#11 Updated by Eric Helms about 7 years ago

  • Is duplicate of Feature #5280: As a user I want to be able to specify per org, per product and per repository proxy configuration added

#12 Updated by Stephen Benjamin almost 7 years ago

  • Bugzilla link deleted (1132980)

#13 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

#14 Updated by Eric Helms over 5 years ago

  • Related to Feature #17425: Support bypassing proxy for some repository URLs added

#15 Updated by Eric Helms over 5 years ago

  • Related to deleted (Feature #17425: Support bypassing proxy for some repository URLs)

Also available in: Atom PDF