Project

General

Profile

Feature #9536

katello-installer should set default_organization and default_location settings

Added by Pat Riehecky over 5 years ago. Updated 9 months ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
Installer
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

It would be helpful for the katello installer to have an option to automatically register the host with foreman. As a part of the installation it knows the admin user/pass and could use the foreman API to define the host.

Obviously it wouldn't have an associated lifecycle environment, but it could be placed into the value of --foreman-initial-organization for organizational purposes.

History

#1 Updated by Stephen Benjamin about 5 years ago

  • Subject changed from katello-installer register host automatically to katello-installer should set default_organization and default_location settings

The installer won't explicitly, but the first time Puppet runs, the host will get added, and we turn on the puppet agent by default.

The problem is you may not see it, as the host is not added to any organization. Switch to "Any Context" and you will.

We should set the default organization for all new hosts in Katello.

#2 Updated by Eric Helms about 5 years ago

  • Triaged changed from No to Yes

#3 Updated by Eric Helms over 4 years ago

  • Legacy Backlogs Release (now unused) set to 114

#4 Updated by John Mitsch 9 months ago

  • Target version deleted (Katello Backlog)
  • Status changed from New to Rejected

Thanks for reporting this issue. This issue was created over 4 years ago and hasn't seen an update in 1 year. We are closing this in an effort to keep a realistic backlog. Please open up a new issue that includes a link to this issue if you feel this still needs to be addressed. We can then triage the new issue and reassess.

Also available in: Atom PDF