Project

General

Profile

Actions

Bug #9544

closed

downcase_hash_keys function missing

Added by Christopher Williamson almost 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
-
Difficulty:
easy
Triaged:
Fixed in Releases:
Found in Releases:

Description

Hi guys,

I recently confirmed a bug (9242) which has since been resolved but the resolution has brought another bug to my attention preventing the image search from completing on foreman for me at this time.

I have tracked the issue down to the file:

/usr/share/foreman/vendor/ruby/1.9.1/gems/foreman_docker-1.2.0/app/models/concerns/fog_extensions/fogdocker/images.rb

It looks like the module necessary to provide 'downcase_hash_keys' has not been included in this module sadly. I have managed to workaround this by adding the following:

def downcase_hash_keys(hash, k = [])
return {k.join('_').gsub(/([a-z])([A-Z])/,'\1_\2').downcase => hash} unless hash.is_a?(Hash)
hash.reduce({}){ |h, v| h.merge! downcase_hash_keys(v[-1], k + [v[0]]) }
end

This is, however, very hacky and should be resolved by including the correct module in my opinion.

Please let me know if you need any further information.

Actions #1

Updated by Anonymous almost 9 years ago

  • Status changed from New to Assigned
  • Assignee set to Anonymous
Actions #2

Updated by The Foreman Bot almost 9 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-docker/pull/100 added
  • Pull request deleted ()
Actions #3

Updated by Anonymous almost 9 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF