Project

General

Profile

Refactor #96

config/settings.yaml should not be under git control

Added by Martin Englund about 12 years ago. Updated about 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

It is a host specific file which shouldn't be touched when you pull new changes.

Instead it should be distributed as config/settings.yaml.example


Related issues

Is duplicate of Foreman - Refactor #343: settings file should not be under version controlClosed2010-07-06

History

#1 Updated by Ohad Levy about 12 years ago

do you know of a way of removing it from git but not removing the file (for the people who do git pull?)

#2 Updated by Martin Englund about 12 years ago

  • Assignee set to Ohad Levy

just run

git mv config/settings.yaml config/settings.yaml.example

#3 Updated by Ohad Levy about 12 years ago

Martin Englund wrote:

just run
[...]

what about the people who already use it? :-\

#4 Updated by Martin Englund about 12 years ago

I think you have to put in the release notes to re-create the settings.yaml file, as there is no way to ungit a file and still leave it (as far as I know, but I'm not a git expert, nor do I play one on TV)

#5 Updated by Martin Englund about 12 years ago

btw, database.yml should also not be under git control

#6 Updated by Ohad Levy about 11 years ago

  • Status changed from New to Closed

Also available in: Atom PDF