Project

General

Profile

Feature #9671

[RFE] Add tooling to ease change of hostname

Added by Mike McCune over 4 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Currently it is non-trivial to change the hostname of a Katello/Foreman server. Requires re-generation of all certificates and most likely manual changes to configuration files.

We need at least clear documentation and if required tooling to make this easier to do. Spacewalk has a similar tool:

https://fedorahosted.org/spacewalk/wiki/SpacewalkHostnameRename


Related issues

Is duplicate of Katello - Feature #17522: Need a server side tool to assist with the process of changing the hostname of the Katello serverClosed2016-11-29

History

#1 Updated by Eric Helms about 4 years ago

  • Triaged changed from No to Yes

#2 Updated by Eric Helms over 3 years ago

  • Legacy Backlogs Release (now unused) set to 114

#3 Updated by Jason Nance over 2 years ago

Is this thread valid for current releases:

https://groups.google.com/forum/#!topic/foreman-users/bEXqxT_r3wk

Seems too easy...

#4 Updated by John Mitsch over 2 years ago

  • Is duplicate of Feature #17522: Need a server side tool to assist with the process of changing the hostname of the Katello server added

#5 Updated by John Mitsch over 2 years ago

  • Status changed from New to Closed

Also available in: Atom PDF