Project

General

Profile

Bug #9681

Provide meaningful options for Activation key - Product Content override

Added by Thomas McKay over 6 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1187805
Description of problem:
Provide meaningful options for Activation key - Product Content override

Version-Release number of selected component (if applicable):
  • apr-util-ldap-1.3.9-3.el6_0.1.x86_64
  • candlepin-0.9.38-1.el6.noarch
  • candlepin-common-1.0.18-1.el6.noarch
  • candlepin-selinux-0.9.38-1.el6.noarch
  • candlepin-tomcat6-0.9.38-1.el6.noarch
  • elasticsearch-0.90.10-7.el6.noarch
  • foreman-1.8.0-0.develop.201501290916git1f0e9bd.el6.noarch
  • foreman-compute-1.8.0-0.develop.201501290916git1f0e9bd.el6.noarch
  • foreman-gce-1.8.0-0.develop.201501290916git1f0e9bd.el6.noarch
  • foreman-libvirt-1.8.0-0.develop.201501290916git1f0e9bd.el6.noarch
  • foreman-ovirt-1.8.0-0.develop.201501290916git1f0e9bd.el6.noarch
  • foreman-postgresql-1.8.0-0.develop.201501290916git1f0e9bd.el6.noarch
  • foreman-proxy-1.8.0-0.develop.201501280951gite1bc928.el6.noarch
  • foreman-release-1.8.0-0.develop.201501290916git1f0e9bd.el6.noarch
  • foreman-selinux-1.8.0-0.develop.201412151103gite2863e4.el6.noarch
  • foreman-vmware-1.8.0-0.develop.201501290916git1f0e9bd.el6.noarch
  • katello-2.1.0-1.201411061509gitb0b8f43.el6.noarch
  • katello-certs-tools-2.0.1-1.el6.noarch
  • katello-default-ca-1.0-1.noarch
  • katello-installer-2.2.0-1.201501272021gitf707d62.el6.noarch
  • katello-installer-base-2.2.0-1.201501272021gitf707d62.el6.noarch
  • katello-repos-2.1.1-1.el6.noarch
  • katello-server-ca-1.0-1.noarch
  • openldap-2.4.39-8.el6.x86_64
  • openldap-devel-2.4.39-8.el6.x86_64
  • pulp-docker-plugins-0.2.1-0.2.beta.el6.noarch
  • pulp-katello-0.3-3.el6.noarch
  • pulp-nodes-common-2.5.1-1.el6.noarch
  • pulp-nodes-parent-2.5.1-1.el6.noarch
  • pulp-puppet-plugins-2.5.1-1.el6.noarch
  • pulp-puppet-tools-2.5.1-1.el6.noarch
  • pulp-rpm-plugins-2.5.1-1.el6.noarch
  • pulp-selinux-2.5.1-1.el6.noarch
  • pulp-server-2.5.1-1.el6.noarch
  • python-ldap-2.3.10-1.el6.x86_64
  • ruby193-rubygem-ldap_fluff-0.3.3-1.el6.noarch
  • ruby193-rubygem-net-ldap-0.10.0-1.el6.noarch
  • ruby193-rubygem-runcible-1.3.0-1.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Select an Activation key
2. Go to Product Content Tab
3. Review the Enabled? dropdown.

Actual results:
It has the following options for one of my repos:

Yes (Default)
Override to Yes
Override to No

Expected results:

As a sat6 user, I like to see only what is relevant to me, that is:

Yes (Default)
Override to No

And in default disabled product, I should see:

No (Default)
Override to Yes

Additional info:

Associated revisions

Revision 32da9fa0 (diff)
Added by Thomas McKay over 6 years ago

fixes #9681 - simplify presented content override choices

Revision d3171a10
Added by Thomas McKay over 6 years ago

Merge pull request #5091 from thomasmckay/9681-content-override

fixes #9681 - simplify presented content override choices

History

#1 Updated by Eric Helms over 6 years ago

  • Legacy Backlogs Release (now unused) set to 31
  • Triaged changed from No to Yes

#2 Updated by Thomas McKay over 6 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF