Project

General

Profile

Bug #9696

LDAP auth source base DN and password missing from API responses

Added by Kendall Moore about 5 years ago. Updated about 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
API
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

auth_source_ldaps does not return the values groups_base or account_password via a GET request.


Related issues

Is duplicate of Foreman - Bug #14286: GET/POST/PUT /api/v2/auth_source_ldaps/ do not return 'groups_base' attributeClosed2016-03-20

History

#1 Updated by Dominic Cleal about 5 years ago

  • Subject changed from REST API Not Returning Values to LDAP auth source base DN and password missing from API responses
  • Category set to API

#2 Updated by Dominic Cleal about 4 years ago

  • Is duplicate of Bug #14286: GET/POST/PUT /api/v2/auth_source_ldaps/ do not return 'groups_base' attribute added

#3 Updated by Dominic Cleal about 4 years ago

  • Status changed from New to Duplicate

Thanks for the report, this has now been fixed under ticket #14286. I don't think we would put the account password into the API response so it's write-only.

Also available in: Atom PDF