Project

General

Profile

Actions

Bug #9776

closed

foreman does not show a warning if a dhcp reservation already exists and simply fails

Added by Mattias Giese about 9 years ago. Updated over 7 years ago.

Status:
Rejected
Priority:
High
Assignee:
-
Category:
Host creation
Target version:
-
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

Heya,

as the subject suggests. If i try to add a new host with a hostname that was defined earlier Foreman does not show a warning.
It simply fails while adding the dhcp reservation: http://pastebin.centos.org/16936/
This also occurs while using the Discovery plugin (3.0.0).

In earlier versions, a popup was displayed with a warning which let me choose to overwrite the existing reservation with a new one.


Related issues 1 (0 open1 closed)

Related to Foreman - Bug #8727: Discovered hosts with same MAC address are reported as DHCP conflictsClosedGreg Sutcliffe12/16/2014Actions
Actions #1

Updated by Dominic Cleal about 9 years ago

  • translation missing: en.field_release set to 28
Actions #2

Updated by Lukas Zapletal about 9 years ago

Please upgrade to Foreman 1.8 RC2 which contains a fix for related bug #9776. It may fix this.

Can you describe how can I reproduce this behavior?

Actions #3

Updated by Lukas Zapletal about 9 years ago

  • Related to Bug #8727: Discovered hosts with same MAC address are reported as DHCP conflicts added
Actions #4

Updated by Lukas Zapletal about 9 years ago

Sorry I meant #8727.

Actions #5

Updated by Dominic Cleal about 9 years ago

  • Status changed from New to Need more information
Actions #6

Updated by Dominic Cleal almost 9 years ago

  • Status changed from Need more information to Feedback
  • translation missing: en.field_release deleted (28)
Actions #7

Updated by Lukas Zapletal over 7 years ago

I am unable to reproduce this one with latest release.

Actions #8

Updated by Lukas Zapletal over 7 years ago

  • Status changed from Feedback to Rejected

Feel free to reopen if needed.

Actions

Also available in: Atom PDF