Project

General

Profile

Bug #9786

Search does not work on Content host errata tab

Added by Justin Sherrill over 6 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Category:
Web UI
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1179462
Description of problem:
Search does not work on Content host errata tab

Version-Release number of selected component (if applicable):
  • apr-util-ldap-1.3.9-3.el6_0.1.x86_64
  • candlepin-0.9.37-1.el6.noarch
  • candlepin-common-1.0.17-1.el6.noarch
  • candlepin-selinux-0.9.37-1.el6.noarch
  • candlepin-tomcat6-0.9.37-1.el6.noarch
  • elasticsearch-0.90.10-7.el6.noarch
  • foreman-1.8.0-0.develop.201501051457git6529247.el6.noarch
  • foreman-compute-1.8.0-0.develop.201501051457git6529247.el6.noarch
  • foreman-gce-1.8.0-0.develop.201501051457git6529247.el6.noarch
  • foreman-libvirt-1.8.0-0.develop.201501051457git6529247.el6.noarch
  • foreman-ovirt-1.8.0-0.develop.201501051457git6529247.el6.noarch
  • foreman-postgresql-1.8.0-0.develop.201501051457git6529247.el6.noarch
  • foreman-proxy-1.8.0-0.develop.201412301259gite2ce2a0.el6.noarch
  • foreman-release-1.8.0-0.develop.201501051457git6529247.el6.noarch
  • foreman-selinux-1.8.0-0.develop.201412151103gite2863e4.el6.noarch
  • foreman-vmware-1.8.0-0.develop.201501051457git6529247.el6.noarch
  • katello-2.1.0-1.201411061509gitb0b8f43.el6.noarch
  • katello-certs-tools-2.0.1-1.el6.noarch
  • katello-default-ca-1.0-1.noarch
  • katello-installer-2.2.0-1.201412192027git113612b.el6.noarch
  • katello-installer-base-2.2.0-1.201412192027git113612b.el6.noarch
  • katello-repos-2.1.1-1.el6.noarch
  • katello-server-ca-1.0-1.noarch
  • openldap-2.4.23-32.el6_4.1.x86_64
  • openldap-devel-2.4.23-32.el6_4.1.x86_64
  • pulp-docker-plugins-0.2.1-0.2.beta.el6.noarch
  • pulp-katello-0.3-3.el6.noarch
  • pulp-nodes-common-2.5.1-1.el6.noarch
  • pulp-nodes-parent-2.5.1-1.el6.noarch
  • pulp-puppet-plugins-2.5.1-1.el6.noarch
  • pulp-puppet-tools-2.5.1-1.el6.noarch
  • pulp-rpm-plugins-2.5.1-1.el6.noarch
  • pulp-selinux-2.5.1-1.el6.noarch
  • pulp-server-2.5.1-1.el6.noarch
  • python-ldap-2.3.10-1.el6.x86_64
  • ruby193-rubygem-ldap_fluff-0.3.3-1.el6.noarch
  • ruby193-rubygem-net-ldap-0.10.0-1.el6.noarch
  • ruby193-rubygem-runcible-1.3.0-1.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Navigate to Web UI > content host -> Errata tab -> Search
2. I tried searching the following, none of them worked:
rsyslog bug fix update (Note: there is an errata with this title)
- title= rsyslog bug fix update
- title: rsyslog bug fix update
- RHSA-2014:2024 (Note: there is an errata with this id)
- Id= RHSA-2014:2024
- Id: RHSA-2014:2024

Actual results:
None of the above mentioned search showed results

Expected results:
The right errata item should be displayed

Additional info:

Associated revisions

Revision c063ff97 (diff)
Added by Justin Sherrill over 6 years ago

fixes #9786 - fixing searching and adding pagination to hosts errata

This makes a number of changes around content host errata:
  • Moves the errata list api call to the system_errata_controller
  • Adds autocomplete
  • Refactors scoped_search() to allow includes to be passed in (since it ignores them)
  • changes UI to use pagination

Revision 5c137562
Added by Justin Sherrill over 6 years ago

Merge pull request #5112 from jlsherrill/9786

fixes #9786 - fixing searching and adding pagination to hosts errata

History

#1 Updated by Justin Sherrill over 6 years ago

  • Status changed from New to Assigned
  • Target version set to 68
  • Difficulty set to easy

#2 Updated by The Foreman Bot over 6 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5112 added
  • Pull request deleted ()

#3 Updated by Eric Helms over 6 years ago

  • Legacy Backlogs Release (now unused) set to 31
  • Triaged changed from No to Yes

#4 Updated by Justin Sherrill over 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF