Project

General

Profile

Bug #9797

undefined method error on 'hammer content-view version list' command

Added by Adam Price about 7 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Hammer
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

i run 'hammer content-view version list' expecting the help output of what options are available, but instead i get:


undefined method `pulp_id' for nil:NilClass

Related issues

Is duplicate of Katello - Bug #9741: hammer: content-view version list failedClosed2015-03-12

History

#1 Updated by Adam Price about 7 years ago

run with hammer's verbose and debug flags:


$ hammer --verbose --debug content-view version list
[ INFO 2015-03-17 15:49:45 Init] Initialization of Hammer CLI (0.1.4) has started...
[DEBUG 2015-03-17 15:49:45 Init] Running at ruby 1.9.3-p551
[ INFO 2015-03-17 15:49:45 Init] Configuration from the file /home/adprice/.hammer/cli_config.yml has been loaded
[ INFO 2015-03-17 15:49:45 Init] Configuration from the file /home/adprice/.hammer/cli.modules.d/console.yml has been loaded
[ INFO 2015-03-17 15:49:45 Init] Configuration from the file /home/adprice/.hammer/cli.modules.d/foreman.yml has been loaded
[ INFO 2015-03-17 15:49:45 Init] Configuration from the file /home/adprice/.hammer/cli.modules.d/foreman_bootdisk.yml has been loaded
[ INFO 2015-03-17 15:49:45 Init] Configuration from the file /home/adprice/.hammer/cli.modules.d/gutterball.yml has been loaded
[ INFO 2015-03-17 15:49:45 Init] Configuration from the file /home/adprice/.hammer/cli.modules.d/katello.yml has been loaded
[ INFO 2015-03-17 15:49:45 Init] Configuration from the file /home/adprice/.hammer/cli.modules.d/sam.yml has been loaded
[ INFO 2015-03-17 15:49:45 Modules] Extension module hammer_cli_console (0.0.1) loaded
[DEBUG 2015-03-17 15:49:46 Connection] Registered: foreman
[DEBUG 2015-03-17 15:49:46 API] Global headers: {
        :content_type => "application/json",
              :accept => "application/json;version=2",
    "Accept-Language" => "en" 
}
[ INFO 2015-03-17 15:49:46 API] GET /apidoc/apipie_checksum
[DEBUG 2015-03-17 15:49:46 API] Params: {}
[DEBUG 2015-03-17 15:49:46 API] Headers: {
    :accept => "application/json",
    :params => {}
}
[DEBUG 2015-03-17 15:49:46 API] Response: {
    "checksum" => "fcfc908aaad717ac95059f6ca4c0a2e3" 
}
[DEBUG 2015-03-17 15:49:46 API] Response headers: {
       :content_type => "application/json; charset=utf-8",
    :apipie_checksum => "fcfc908aaad717ac95059f6ca4c0a2e3",
    :x_ua_compatible => "IE=Edge",
               :etag => "\"4041b34a46691fa9acdb6b0c7f7fb2d4\"",
      :cache_control => "max-age=0, private, must-revalidate",
       :x_request_id => "d73ba82a20c4e6d4c6b6dc2c16bcb848",
          :x_runtime => "0.076919",
             :server => "WEBrick/1.3.1 (Ruby/1.9.3/2014-11-13)",
               :date => "Tue, 17 Mar 2015 19:49:46 GMT",
     :content_length => "51",
         :connection => "Keep-Alive",
         :set_cookie => [
        [0] "request_method=; path=/; expires=Thu, 01-Jan-1970 00:00:00 GMT" 
    ]
}
[ INFO 2015-03-17 15:49:46 Modules] Extension module hammer_cli_foreman (0.1.4) loaded
[ INFO 2015-03-17 15:49:46 Modules] Extension module hammer_cli_foreman_bootdisk (0.1.2) loaded
[ INFO 2015-03-17 15:49:46 HammerCLI::MainCommand] subcommand organization (HammerCLIForeman::Organization) was removed.
[ INFO 2015-03-17 15:49:46 HammerCLI::MainCommand] subcommand organization (HammerCLIKatello::Organization) was created.
[ INFO 2015-03-17 15:49:46 Modules] Extension module hammer_cli_gutterball (1.0.0) loaded
[ INFO 2015-03-17 15:49:46 Modules] Extension module hammer_cli_katello (0.0.8) loaded
[DEBUG 2015-03-17 15:49:46 Init] Using locale 'en'
[DEBUG 2015-03-17 15:49:46 Init] 'mo' files for locale domain 'hammer-cli' loaded from '/home/adprice/hammer-cli/locale'
[DEBUG 2015-03-17 15:49:46 Init] 'mo' files for locale domain 'hammer-cli-foreman' loaded from '/home/adprice/hammer-cli-foreman/locale'
[DEBUG 2015-03-17 15:49:46 Init] 'mo' files for locale domain 'hammer-cli-katello' loaded from '/home/adprice/hammer-cli-katello/locale'
[ INFO 2015-03-17 15:49:46 HammerCLI::MainCommand] Called with options: {"option_verbose"=>true, "option_debug"=>true}
[ INFO 2015-03-17 15:49:46 HammerCLIKatello::ContentView] Called with options: {}
[ INFO 2015-03-17 15:49:46 HammerCLIKatello::ContentViewVersion] Called with options: {}
[ INFO 2015-03-17 15:49:46 HammerCLIKatello::ContentViewVersion::ListCommand] Called with options: {}
[ INFO 2015-03-17 15:49:46 API] GET /apidoc/apipie_checksum
[DEBUG 2015-03-17 15:49:46 API] Params: {}
[DEBUG 2015-03-17 15:49:46 API] Headers: {
    :accept => "application/json",
    :params => {}
}
[DEBUG 2015-03-17 15:49:47 API] Response: {
    "checksum" => "fcfc908aaad717ac95059f6ca4c0a2e3" 
}
[DEBUG 2015-03-17 15:49:47 API] Response headers: {
       :content_type => "application/json; charset=utf-8",
    :apipie_checksum => "fcfc908aaad717ac95059f6ca4c0a2e3",
    :x_ua_compatible => "IE=Edge",
               :etag => "\"4041b34a46691fa9acdb6b0c7f7fb2d4\"",
      :cache_control => "max-age=0, private, must-revalidate",
       :x_request_id => "8875bb08e48315552ec276997656ce47",
          :x_runtime => "0.073118",
             :server => "WEBrick/1.3.1 (Ruby/1.9.3/2014-11-13)",
               :date => "Tue, 17 Mar 2015 19:49:47 GMT",
     :content_length => "51",
         :connection => "Keep-Alive",
         :set_cookie => [
        [0] "request_method=; path=/; expires=Thu, 01-Jan-1970 00:00:00 GMT" 
    ]
}
[ INFO 2015-03-17 15:49:47 API] GET /katello/api/content_view_versions
[DEBUG 2015-03-17 15:49:47 API] Params: {}
[DEBUG 2015-03-17 15:49:47 API] Headers: {
    :params => {}
}
[DEBUG 2015-03-17 15:49:47 API] 500 Internal Server Error
{
    "displayMessage" => "undefined method `pulp_id' for nil:NilClass",
            "errors" => [
        [0] "undefined method `pulp_id' for nil:NilClass" 
    ]
}
[ERROR 2015-03-17 15:49:47 Exception] undefined method `pulp_id' for nil:NilClass
undefined method `pulp_id' for nil:NilClass
[ERROR 2015-03-17 15:49:47 Exception]

RestClient::InternalServerError (500 Internal Server Error):
    /home/adprice/.rvm/gems/ruby-1.9.3-p551@hammer/gems/rest-client-1.6.8/lib/restclient/abstract_response.rb:48:in `return!'
    /home/adprice/.rvm/gems/ruby-1.9.3-p551@hammer/gems/rest-client-1.6.8/lib/restclient/request.rb:269:in `process_result'
    /home/adprice/.rvm/gems/ruby-1.9.3-p551@hammer/gems/rest-client-1.6.8/lib/restclient/request.rb:212:in `block in transmit'
    /home/adprice/.rvm/rubies/ruby-1.9.3-p551/lib/ruby/1.9.1/net/http.rb:746:in `start'
    /home/adprice/.rvm/gems/ruby-1.9.3-p551@hammer/gems/rest-client-1.6.8/lib/restclient/request.rb:206:in `transmit'
    /home/adprice/.rvm/gems/ruby-1.9.3-p551@hammer/gems/rest-client-1.6.8/lib/restclient/request.rb:68:in `execute'
    /home/adprice/.rvm/gems/ruby-1.9.3-p551@hammer/gems/rest-client-1.6.8/lib/restclient/request.rb:35:in `execute'
    /home/adprice/.rvm/gems/ruby-1.9.3-p551@hammer/gems/rest-client-1.6.8/lib/restclient/resource.rb:51:in `get'
    /home/adprice/.rvm/gems/ruby-1.9.3-p551@hammer/gems/apipie-bindings-0.0.11/lib/apipie_bindings/api.rb:279:in `call_client'
    /home/adprice/.rvm/gems/ruby-1.9.3-p551@hammer/gems/apipie-bindings-0.0.11/lib/apipie_bindings/api.rb:210:in `http_call'
    /home/adprice/.rvm/gems/ruby-1.9.3-p551@hammer/gems/apipie-bindings-0.0.11/lib/apipie_bindings/api.rb:161:in `call'
    /home/adprice/.rvm/gems/ruby-1.9.3-p551@hammer/gems/apipie-bindings-0.0.11/lib/apipie_bindings/resource.rb:14:in `call'
    /home/adprice/hammer-cli/lib/hammer_cli/apipie/command.rb:43:in `send_request'
    /home/adprice/hammer-cli-foreman/lib/hammer_cli_foreman/commands.rb:179:in `send_request'
    /home/adprice/hammer-cli-foreman/lib/hammer_cli_foreman/commands.rb:257:in `send_request'
    /home/adprice/hammer-cli-foreman/lib/hammer_cli_foreman/commands.rb:306:in `retrieve_and_print'
    /home/adprice/hammer-cli-foreman/lib/hammer_cli_foreman/commands.rb:280:in `execute'
    /home/adprice/.rvm/gems/ruby-1.9.3-p551@hammer/gems/clamp-0.6.4/lib/clamp/command.rb:67:in `run'
    /home/adprice/hammer-cli/lib/hammer_cli/abstract.rb:23:in `run'
    /home/adprice/.rvm/gems/ruby-1.9.3-p551@hammer/gems/clamp-0.6.4/lib/clamp/subcommand/execution.rb:11:in `execute'
    /home/adprice/.rvm/gems/ruby-1.9.3-p551@hammer/gems/clamp-0.6.4/lib/clamp/command.rb:67:in `run'
    /home/adprice/hammer-cli/lib/hammer_cli/abstract.rb:23:in `run'
    /home/adprice/.rvm/gems/ruby-1.9.3-p551@hammer/gems/clamp-0.6.4/lib/clamp/subcommand/execution.rb:11:in `execute'
    /home/adprice/.rvm/gems/ruby-1.9.3-p551@hammer/gems/clamp-0.6.4/lib/clamp/command.rb:67:in `run'
    /home/adprice/hammer-cli/lib/hammer_cli/abstract.rb:23:in `run'
    /home/adprice/.rvm/gems/ruby-1.9.3-p551@hammer/gems/clamp-0.6.4/lib/clamp/subcommand/execution.rb:11:in `execute'
    /home/adprice/.rvm/gems/ruby-1.9.3-p551@hammer/gems/clamp-0.6.4/lib/clamp/command.rb:67:in `run'
    /home/adprice/hammer-cli/lib/hammer_cli/abstract.rb:23:in `run'
    /home/adprice/.rvm/gems/ruby-1.9.3-p551@hammer/gems/clamp-0.6.4/lib/clamp/command.rb:132:in `run'
    /home/adprice/hammer-cli/bin/hammer:108:in `<top (required)>'
    /home/adprice/.rvm/gems/ruby-1.9.3-p551@hammer/bin/hammer:23:in `load'
    /home/adprice/.rvm/gems/ruby-1.9.3-p551@hammer/bin/hammer:23:in `<main>'
    /home/adprice/.rvm/gems/ruby-1.9.3-p551@hammer/bin/ruby_executable_hooks:15:in `eval'
    /home/adprice/.rvm/gems/ruby-1.9.3-p551@hammer/bin/ruby_executable_hooks:15:in `<main>'

#2 Updated by Eric Helms about 7 years ago

  • Status changed from New to Duplicate
  • Triaged changed from No to Yes

#3 Updated by Eric Helms about 7 years ago

  • Is duplicate of Bug #9741: hammer: content-view version list failed added

#4 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF