Project

General

Profile

Feature #9822

Support Puppet 4 / future parser across all modules

Added by Dominic Cleal almost 5 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Foreman modules
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Tracker for modules to support Puppet 4, with its "future" parser, strict variables etc.

https://github.com/theforeman/foreman-installer-modulesync/pull/11 tracks our own modules for the future parser.

Strict variables have yet to be tested.

External modules also need checking.


Related issues

Related to Installer - Bug #10328: foreman-installer has kafo errors when future parser is enabledDuplicate2015-04-30
Related to Katello - Bug #15217: Support puppet 4.0 in all our installer modulesNew2016-05-27
Blocks Foreman - Tracker #8447: Puppet 4 supportClosed2014-11-19

History

#1 Updated by Dominic Cleal almost 5 years ago

#3 Updated by Marek Hulán over 4 years ago

  • Related to Bug #10328: foreman-installer has kafo errors when future parser is enabled added

#4 Updated by Michael Moll about 4 years ago

I guess this can be closed now? :)

#5 Updated by Dominic Cleal about 4 years ago

#6 Updated by Dominic Cleal about 4 years ago

#7 Updated by Dominic Cleal about 4 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100
  • Legacy Backlogs Release (now unused) set to 71

Yep, all master branches for our modules should now support the Puppet 4 parser.

#8 Updated by Stephen Benjamin over 3 years ago

  • Related to Bug #15217: Support puppet 4.0 in all our installer modules added

Also available in: Atom PDF