Project

General

Profile

Bug #9872

Sat6 Content Hosts unusable after candlepin has an error in finding a unit

Added by Eric Helms over 7 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
API
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1201818
Description of problem:
This issue is about the failure tolerance of Sat6 and not the Candlepin error.

Listing content hosts is not possible anymore once candlepin has an error that it cannot find a unit. The result is that managing any other content hosts(e.g. content view change) and its subscriptions in the UI is not possible and you cannot use Sat6 anymore.

time curl -K /opt/hoici/etc/sat6/curl-hoici.conf "-HContent-Type: application/json" "-d{\"per_page\":9999}" -XGET https://localhost/katello/api/v2/organizations/4/systems | jq . {
"errors": [
"Katello::Resources::Candlepin::Consumer: 410 Gone {\"displayMessage\":\"Unit fb3480f1-401a-42dc-aab6-d9d9674c4a7e has been deleted\",\"requestUuid\":\"4e48eef6-f70a-4adf-b2aa-d3ae967af02e\",\"deletedId\":\"fb3480f1-401a-42dc-aab6-d9d9674c4a7e\"} (GET /candlepin/consumers/fb3480f1-401a-42dc-aab6-d9d9674c4a7e)"
],
"displayMessage": "Katello::Resources::Candlepin::Consumer: 410 Gone {\"displayMessage\":\"Unit fb3480f1-401a-42dc-aab6-d9d9674c4a7e has been deleted\",\"requestUuid\":\"4e48eef6-f70a-4adf-b2aa-d3ae967af02e\",\"deletedId\":\"fb3480f1-401a-42dc-aab6-d9d9674c4a7e\"} (GET /candlepin/consumers/fb3480f1-401a-42dc-aab6-d9d9674c4a7e)"
}

real 0m41.867s
user 0m0.181s
sys 0m0.052s

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Sat6 Content Hosts shall be more tolerant against errors in candlepin
2.
3.

Actual results:
Sat6 has become unusable.

Expected results:
Sat6 is still usable for other content hosts.

Additional info:

Associated revisions

Revision 2e21704f (diff)
Added by Eric Helms over 7 years ago

Fixes #9872: Properly destroy systems that are of type Hypervisor.

The Foreman Tasks input object attempts to build a hash based on the
class name being passed in as the action subject. Since the Hypervisor
class inherits from system, and calls the system destroy the action
generated input[:hypervisor] even though the finalize expected a hash
with input[:system]. This prevented hyprvisor deletion from the database
and leads to 410 gone in Candlepin.

Revision 45e08db9
Added by Eric Helms over 7 years ago

Merge pull request #5130 from ehelms/fixes-9872

Fixes #9872: Properly destroy systems that are of type Hypervisor.

History

#1 Updated by Eric Helms over 7 years ago

  • Category set to API
  • Target version set to 68
  • Legacy Backlogs Release (now unused) set to 23
  • Triaged changed from No to Yes

#2 Updated by The Foreman Bot over 7 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5130 added
  • Pull request deleted ()

#3 Updated by Eric Helms over 7 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF